summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatti Niemenmaa2017-05-03 14:45:46 +0300
committerMatti Niemenmaa2017-05-03 14:45:46 +0300
commitbe70cb789ba633545dfa29cd1a579577bcc831e5 (patch)
tree3c70e74ed945fd9e7a023516f9e728a5cecb7d9c
parent7923c486429bb190bc06bfdab88926f101045d51 (diff)
downloadaur-be70cb789ba633545dfa29cd1a579577bcc831e5.tar.gz
Patch a Makefile so that coding_utils.c is linked
Without this the library doesn't work at all, since the symbols are required.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--libcoding-utils.patch9
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a77041e8221..eefca89f9d13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vgmstream-kode54-git
pkgdesc = Library for playback of various streamed audio formats used in video games (kode54's fork)
pkgver = r1020.r557.gd2fac79
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.kode54.net/kode54/vgmstream
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = vgmstream-kode54-git
depends = libvorbis
depends = mpg123
source = vgmstream-kode54-git::git+https://gitlab.kode54.net/kode54/vgmstream.git
+ source = libcoding-utils.patch
sha256sums = SKIP
+ sha256sums = 3ae17fca859443b8d75dde83fa511111dee016e5bf2c5cb86c6786929ee30da3
pkgname = vgmstream-kode54-git
diff --git a/PKGBUILD b/PKGBUILD
index 33fc86bc7d35..d43239fb7948 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
pkgname=vgmstream-kode54-git
pkgver=r1020.r557.gd2fac79
-pkgrel=1
+pkgrel=2
pkgdesc="Library for playback of various streamed audio formats used in video games (kode54's fork)"
arch=(i686 x86_64)
url='https://gitlab.kode54.net/kode54/vgmstream'
license=(BSD)
depends=(glibc libogg libvorbis mpg123)
makedepends=(git)
-source=(${pkgname}::git+https://gitlab.kode54.net/kode54/vgmstream.git)
-sha256sums=('SKIP')
+source=(${pkgname}::git+https://gitlab.kode54.net/kode54/vgmstream.git
+ libcoding-utils.patch)
+sha256sums=('SKIP'
+ '3ae17fca859443b8d75dde83fa511111dee016e5bf2c5cb86c6786929ee30da3')
pkgver() {
cd "$srcdir/$pkgname"
@@ -18,10 +20,16 @@ pkgver() {
)
}
-build() {
+prepare() {
cd "$srcdir/$pkgname"
+ patch -Np0 -i "$srcdir/libcoding-utils.patch"
+
# We won't build the Audacious plugin so we don't need the libraries either.
sed -i '/PKG_CHECK_MODULES(\(AUDACIOUS\|GTK\)/{N;N;d}' configure.in
+}
+
+build() {
+ cd "$srcdir/$pkgname"
./bootstrap
CFLAGS="$CFLAGS -I../ext_includes -I../../ext_includes" ./configure
cd src
diff --git a/libcoding-utils.patch b/libcoding-utils.patch
new file mode 100644
index 000000000000..a4323f91d341
--- /dev/null
+++ b/libcoding-utils.patch
@@ -0,0 +1,9 @@
+--- src/coding/Makefile.unix.am 2017-05-03 14:33:52.616081736 +0300
++++ src/coding/Makefile.unix.am 2017-05-03 14:35:17.252218027 +0300
+@@ -35,5 +35,6 @@
+ libcoding_la_SOURCES += wwise_vorbis_decoder.c
+ libcoding_la_SOURCES += wwise_vorbis_utils.c
+ libcoding_la_SOURCES += ogl_vorbis_decoder.c
++libcoding_la_SOURCES += coding_utils.c
+
+ EXTRA_DIST = coding.h g72x_state.h clHCA.h