summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEcho J2023-04-12 16:15:45 +0300
committerEcho J2023-04-12 16:15:45 +0300
commit045f0a9770889767723ca9fce7f201051120e4f3 (patch)
treed7ce56cbea211d695fe4859bb59f89e3db087ef2
parent1af51e637432ff0d49fc3415eb74d47407a48cd1 (diff)
downloadaur-045f0a9770889767723ca9fce7f201051120e4f3.tar.gz
Fix a compile error
-rwxr-xr-xPKGBUILD11
-rw-r--r--fix-header-import.patch24
2 files changed, 31 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8dcd5d48d59f..52b8d674e05f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=vgmtrans
pkgname=${_pkgname}-git
# Use the latest commit's date and then the number of revisions using the same command as on line 19.
-pkgver=20210708.r966.156e8ae
+pkgver=20230326.r1142.aeea082
pkgrel=1
pkgdesc="Converter for sequenced videogame music"
arch=("x86_64")
@@ -12,12 +12,15 @@ license=("ZLIB")
depends=("qt6-base" "fluidsynth" "qt6-svg" "minizip")
makedepends=("qt6-tools" "cmake" "git")
optdepends=("qt6-wayland: Wayland support")
-source=("${_pkgname}::git+${url}")
-sha256sums=("SKIP")
+source=("${_pkgname}::git+${url}"
+ fix-header-import.patch)
+sha256sums=("SKIP"
+ "85caf04f1644abc66e87e5f67cb67281a50ee50ace2213efbcf2a80e3fa5ad9d")
prepare() {
cd "${srcdir}/${_pkgname}"
- rm -rf build && mkdir build
+
+ patch -Np1 -i ../fix-header-import.patch
}
pkgver() {
diff --git a/fix-header-import.patch b/fix-header-import.patch
new file mode 100644
index 000000000000..a3ea7560ce3f
--- /dev/null
+++ b/fix-header-import.patch
@@ -0,0 +1,24 @@
+diff --git a/src/main/DLSFile.cpp b/src/main/DLSFile.cpp
+index 495c81e..c935454 100644
+--- a/src/main/DLSFile.cpp
++++ b/src/main/DLSFile.cpp
+@@ -6,7 +6,6 @@
+
+ #include "pch.h"
+ #include <algorithm>
+-#include <memory>
+ #include <numeric>
+ #include "DLSFile.h"
+ #include "VGMInstrSet.h"
+diff --git a/src/main/DLSFile.h b/src/main/DLSFile.h
+index bbe8e9a..15187cf 100644
+--- a/src/main/DLSFile.h
++++ b/src/main/DLSFile.h
+@@ -7,6 +7,7 @@
+ #pragma once
+
+ #include "common.h"
++#include <memory>
+ #include "RiffFile.h"
+
+ struct Loop;