summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-03-14 08:34:46 -0600
committerMark Wagie2020-03-14 08:34:46 -0600
commit16992500efb938377e7aaaec25c53f007cfb9f97 (patch)
tree0fd00f1fbde4e2e1eac1ea77ecce49ab13cc1ef2
parent609068e7f6b59b3146f5f7e987a9c691a7d3f7ef (diff)
downloadaur-16992500efb938377e7aaaec25c53f007cfb9f97.tar.gz
updated to 1.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d28bbbe0888a..c6b498d3474d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = vgrive
pkgdesc = Google Drive client made in Vala
- pkgver = 1.4.0
- pkgrel = 2
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://github.com/bcedu/VGrive
arch = x86_64
license = GPL3
makedepends = meson
makedepends = vala
makedepends = cmake
+ makedepends = appstream-glib
depends = gtk3
depends = granite
- depends = json-glib
depends = libsoup
optdepends = libunity
optdepends = libappindicator-gtk3
- source = vgrive-1.4.0.tar.gz::https://github.com/bcedu/VGrive/archive/1.4.0.tar.gz
- sha256sums = 7630e1e706fb0932c0ebf1e2a7b8c051914a1ec3ea970d8b5c19b5b39a93e82a
+ source = vgrive-1.5.0.tar.gz::https://github.com/bcedu/VGrive/archive/v1.5.0.tar.gz
+ sha256sums = 7d4316d12047c556f53d0d3a05db9a31c5947fd2038f70d234f3bfc748b6755b
pkgname = vgrive
diff --git a/PKGBUILD b/PKGBUILD
index 4dd9fdfefb96..42b2a57483bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=vgrive
-pkgver=1.4.0
-pkgrel=2
+pkgver=1.5.0
+pkgrel=1
pkgdesc="Google Drive client made in Vala"
arch=('x86_64')
url="https://github.com/bcedu/VGrive"
license=('GPL3')
-depends=('gtk3' 'granite' 'json-glib' 'libsoup')
-makedepends=('meson' 'vala' 'cmake')
+depends=('gtk3' 'granite' 'libsoup')
+makedepends=('meson' 'vala' 'cmake' 'appstream-glib')
optdepends=('libunity' 'libappindicator-gtk3')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bcedu/VGrive/archive/$pkgver.tar.gz")
-sha256sums=('7630e1e706fb0932c0ebf1e2a7b8c051914a1ec3ea970d8b5c19b5b39a93e82a')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bcedu/VGrive/archive/v$pkgver.tar.gz")
+sha256sums=('7d4316d12047c556f53d0d3a05db9a31c5947fd2038f70d234f3bfc748b6755b')
build() {
- cd "VGrive-$pkgver"
- arch-meson build
+ arch-meson "VGrive-$pkgver" build
ninja -C build
}
package() {
- cd "VGrive-$pkgver"
DESTDIR="$pkgdir" ninja -C build install
ln -s /usr/bin/com.github.bcedu.vgrive "$pkgdir/usr/bin/$pkgname"
}