summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-17 17:48:33 -0600
committerMark Wagie2021-06-17 17:48:33 -0600
commit4c0c291fb028501b8846f787d8d7b0ac9e91dc57 (patch)
tree15166b4d3b7b9646e02ee8686bb64a84e9c63963
parent10bbedbedb511992567d7e7634041f8648dab562 (diff)
downloadaur-4c0c291fb028501b8846f787d8d7b0ac9e91dc57.tar.gz
add optional deps
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 430709752ba8..24bd47167b13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vgrive
pkgdesc = Google Drive client made in Vala
pkgver = 1.6.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/bcedu/VGrive
arch = x86_64
license = GPL3
@@ -11,11 +11,11 @@ pkgbase = vgrive
depends = gtk3
depends = granite
depends = libsoup
- depends = libappindicator-gtk3
+ optdepends = libappindicator-gtk3: tray icon
+ optdepends = libunity
source = vgrive-1.6.1.tar.gz::https://github.com/bcedu/VGrive/archive/1.6.1.tar.gz
source = https://github.com/bcedu/VGrive/pull/116.patch
sha256sums = f125ef74ce1d53517cc45d69716bb9668847d5c406096306aedf2a1178b4bfde
sha256sums = 1210228c34d35b3b9464df735464c17124fa9d8bb693ccb708370a0bf8b14735
pkgname = vgrive
-
diff --git a/PKGBUILD b/PKGBUILD
index 2e93686f33cd..eb57a5d9d755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=vgrive
pkgver=1.6.1
-pkgrel=4
+pkgrel=5
pkgdesc="Google Drive client made in Vala"
arch=('x86_64')
url="https://github.com/bcedu/VGrive"
license=('GPL3')
-depends=('gtk3' 'granite' 'libsoup' 'libappindicator-gtk3')
+depends=('gtk3' 'granite' 'libsoup')
makedepends=('meson' 'vala' 'wayland-protocols')
+optdepends=('libappindicator-gtk3: tray icon'
+ 'libunity')
#checkdepends=('appstream-glib')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'https://github.com/bcedu/VGrive/pull/116.patch')
@@ -24,9 +26,11 @@ build() {
meson compile -C build
}
-#check() {
-# meson test -C build --print-errorlogs
-#}
+check() {
+
+ # Validate appstream file fails, only validate desktop & schema files
+ meson test 'Validate desktop file' 'Validate schema file' -C build --print-errorlogs
+}
package() {
DESTDIR="$pkgdir" meson install -C build