summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-27 21:43:31 -0600
committerMark Wagie2021-10-27 21:43:31 -0600
commita999f8331c3d4f839f3a8d65435066211b680be4 (patch)
tree0ee0ca7910e554bd6bb60779b0f5fec4b505deec
parent4c0c291fb028501b8846f787d8d7b0ac9e91dc57 (diff)
downloadaur-a999f8331c3d4f839f3a8d65435066211b680be4.tar.gz
libunity is dead
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24bd47167b13..3be653de05b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vgrive
pkgdesc = Google Drive client made in Vala
pkgver = 1.6.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/bcedu/VGrive
arch = x86_64
license = GPL3
@@ -10,9 +10,8 @@ pkgbase = vgrive
makedepends = wayland-protocols
depends = gtk3
depends = granite
+ depends = libappindicator-gtk3
depends = libsoup
- optdepends = libappindicator-gtk3: tray icon
- optdepends = libunity
source = vgrive-1.6.1.tar.gz::https://github.com/bcedu/VGrive/archive/1.6.1.tar.gz
source = https://github.com/bcedu/VGrive/pull/116.patch
sha256sums = f125ef74ce1d53517cc45d69716bb9668847d5c406096306aedf2a1178b4bfde
diff --git a/PKGBUILD b/PKGBUILD
index eb57a5d9d755..fcbb0db7946d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=vgrive
pkgver=1.6.1
-pkgrel=5
+pkgrel=6
pkgdesc="Google Drive client made in Vala"
arch=('x86_64')
url="https://github.com/bcedu/VGrive"
license=('GPL3')
-depends=('gtk3' 'granite' 'libsoup')
+depends=('gtk3' 'granite' 'libappindicator-gtk3' 'libsoup')
makedepends=('meson' 'vala' 'wayland-protocols')
-optdepends=('libappindicator-gtk3: tray icon'
- 'libunity')
#checkdepends=('appstream-glib')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'https://github.com/bcedu/VGrive/pull/116.patch')
@@ -17,23 +15,25 @@ sha256sums=('f125ef74ce1d53517cc45d69716bb9668847d5c406096306aedf2a1178b4bfde'
'1210228c34d35b3b9464df735464c17124fa9d8bb693ccb708370a0bf8b14735')
prepare() {
- cd "VGrive-$pkgver"
- patch -Np1 -i "$srcdir/116.patch"
+ cd "VGrive-$pkgver"
+
+ # Fix compilation errors in new vala
+ patch -Np1 -i "$srcdir/116.patch"
}
build() {
- arch-meson "VGrive-$pkgver" build
- meson compile -C build
+ arch-meson "VGrive-$pkgver" build
+ meson compile -C build
}
check() {
- # Validate appstream file fails, only validate desktop & schema files
- meson test 'Validate desktop file' 'Validate schema file' -C build --print-errorlogs
+ # Validate appstream file fails, only validate desktop & schema files
+ meson test 'Validate desktop file' 'Validate schema file' -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
- ln -s /usr/bin/com.github.bcedu.vgrive "$pkgdir/usr/bin/$pkgname"
+ ln -s /usr/bin/com.github.bcedu.vgrive "$pkgdir/usr/bin/$pkgname"
}