summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-12 15:12:08 -0700
committerMark Wagie2021-03-12 15:12:08 -0700
commitaa3539b52bda28087c44eeeeb06f326623b163cf (patch)
treee090852bd054d73627340a10b0a1d1508a9f1552
parente75d8c32ffc6615b3b427c55f3d6e4f65f28e69d (diff)
downloadaur-aa3539b52bda28087c44eeeeb06f326623b163cf.tar.gz
fix build
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD25
3 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45e5af3414e6..b9a9edf13e1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = vgrive
pkgdesc = Google Drive client made in Vala
pkgver = 1.6.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bcedu/VGrive
arch = x86_64
license = GPL3
makedepends = meson
makedepends = vala
+ makedepends = wayland-protocols
depends = gtk3
depends = granite
depends = libsoup
- optdepends = libunity
- optdepends = libappindicator-gtk3
+ depends = libappindicator-gtk3
source = vgrive-1.6.1.tar.gz::https://github.com/bcedu/VGrive/archive/1.6.1.tar.gz
+ source = https://github.com/bcedu/VGrive/pull/116.patch
sha256sums = f125ef74ce1d53517cc45d69716bb9668847d5c406096306aedf2a1178b4bfde
+ sha256sums = c5095aa681370383119385ba3bbcae03773def30df91d1ef82aad55fd7c0915f
pkgname = vgrive
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 6decd0b2f541..6cc586f51a71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=vgrive
pkgver=1.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="Google Drive client made in Vala"
arch=('x86_64')
url="https://github.com/bcedu/VGrive"
license=('GPL3')
-depends=('gtk3' 'granite' 'libsoup')
-makedepends=('meson' 'vala')
-#checkdepends=('appstream')
-optdepends=('libunity' 'libappindicator-gtk3')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('f125ef74ce1d53517cc45d69716bb9668847d5c406096306aedf2a1178b4bfde')
+depends=('gtk3' 'granite' 'libsoup' 'libappindicator-gtk3')
+makedepends=('meson' 'vala' 'wayland-protocols')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ 'https://github.com/bcedu/VGrive/pull/116.patch')
+sha256sums=('f125ef74ce1d53517cc45d69716bb9668847d5c406096306aedf2a1178b4bfde'
+ 'c5095aa681370383119385ba3bbcae03773def30df91d1ef82aad55fd7c0915f')
+
+prepare() {
+ cd "VGrive-$pkgver"
+ patch -Np1 -i "$srcdir/116.patch"
+}
build() {
arch-meson "VGrive-$pkgver" build
meson compile -C build
}
-#check() {
-# meson test -C build
-#}
+check() {
+ meson test -C build
+}
package() {
DESTDIR="$pkgdir" meson install -C build