summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Lindsay2021-01-18 21:12:58 -0500
committerAaron Lindsay2021-01-18 21:44:27 -0500
commit064026f114177806752c8c3a077ea8c951ef3ef4 (patch)
treed2ec5ac608d2405bb6b72ca2dad2726853e7ae80
parent8db6b89f09dc12dd9020314f7413b6b29b7aa928 (diff)
downloadaur-064026f114177806752c8c3a077ea8c951ef3ef4.tar.gz
symlink /usr/bin/via to /opt/VIA/via
This change allows calling `via` from the command-line without having to provide the full path to /opt/VIA/via or modify your $PATH. This commit also removes an old shell script, which did not appear to be used.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--via3
3 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e907e578b6c..9bd9716df473 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = via-bin
pkgdesc = Yet another keyboard configurator, compatible with over 150 keyboards and easily added to other QMK keyboards.
pkgver = 1.3.1
- pkgrel = 0
+ pkgrel = 1
url = https://caniusevia.com/
arch = any
depends = hicolor-icon-theme
@@ -17,9 +17,7 @@ pkgbase = via-bin
depends = libsecret
provides = via=1.3.1
source = https://github.com/the-via/releases/releases/download/v1.3.1/via-1.3.1-linux.deb
- source = via
md5sums = 5b61cea500307e17a289f6ac99d60de7
- md5sums = dc41d6a454c010ff44c2f22678dbd79e
pkgname = via-bin
diff --git a/PKGBUILD b/PKGBUILD
index e76e50143a7c..37a4ad5b770a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=via
pkgname=$_pkgname-bin
pkgver=1.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Yet another keyboard configurator, compatible with over 150 keyboards and easily added to other QMK keyboards."
arch=(any)
url="https://caniuse$_pkgname.com/"
@@ -20,11 +20,9 @@ depends=("hicolor-icon-theme"
"libappindicator-gtk3"
"libsecret")
_filename=("${_pkgname}-${pkgver}-linux.deb")
-source=("https://github.com/the-$_pkgname/releases/releases/download/v${pkgver}/$_filename"
- via)
+source=("https://github.com/the-$_pkgname/releases/releases/download/v${pkgver}/$_filename")
-md5sums=("5b61cea500307e17a289f6ac99d60de7"
- "dc41d6a454c010ff44c2f22678dbd79e")
+md5sums=("5b61cea500307e17a289f6ac99d60de7")
build() {
mkdir -p "${srcdir}/output"
@@ -34,4 +32,5 @@ build() {
package() {
cp -r "${srcdir}/output/"* "${pkgdir}"
install -d "${pkgdir}"/usr/bin
+ ln -s /opt/VIA/via "${pkgdir}"/usr/bin/via
}
diff --git a/via b/via
deleted file mode 100644
index ad87d6248b17..000000000000
--- a/via
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-/opt/VIA/via %U