summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRex2020-01-23 11:49:59 +0800
committerRex2020-01-23 11:49:59 +0800
commited0afc3f22c2e70d253ae06b87e6423ea0c70039 (patch)
tree5abdea8d0eaedf9f1987c06db3eeecf1f334743f
downloadaur-ed0afc3f22c2e70d253ae06b87e6423ea0c70039.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--via3
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..856a546178b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = via-bin
+ pkgdesc = VIA Configurator, compatible with over over 40 keyboards and easily added to other QMK keyboards.
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://caniusevia.com/
+ arch = any
+ depends = hicolor-icon-theme
+ provides = via=1.2.4
+ source = https://github.com/the-via/releases/releases/download/v1.2.4/via-1.2.4-linux.deb
+ source = via
+ md5sums = 727000af3573ffaad3d5791c791de42e
+ md5sums = dc41d6a454c010ff44c2f22678dbd79e
+
+pkgname = via-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1a0ddb96c49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: timescam <rex.ky.ng at gmail dot com>
+
+_pkgname=via
+pkgname=$_pkgname-bin
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="VIA Configurator, compatible with over over 40 keyboards and easily added to other QMK keyboards."
+arch=(any)
+url="https://caniuse$_pkgname.com/"
+provides=("${_pkgname}=${pkgver}")
+depends=("hicolor-icon-theme")
+_filename=("${_pkgname}-${pkgver}-linux.deb")
+source=("https://github.com/the-$_pkgname/releases/releases/download/v${pkgver}/$_filename"
+ via)
+
+md5sums=("727000af3573ffaad3d5791c791de42e"
+ "dc41d6a454c010ff44c2f22678dbd79e")
+
+build() {
+ mkdir -p "${srcdir}/output"
+ tar -xvf "${srcdir}/data.tar.xz" -C "${srcdir}/output"
+}
+
+package() {
+ cp -r "${srcdir}/output/"* "${pkgdir}"
+ install -d "${pkgdir}"/usr/bin
+} \ No newline at end of file
diff --git a/via b/via
new file mode 100644
index 000000000000..ad87d6248b17
--- /dev/null
+++ b/via
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+/opt/VIA/via %U