summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMako882015-06-11 09:26:13 -0500
committerMako882015-06-11 09:26:13 -0500
commit411d8d64d653bdf49cbc602743f353e014d64606 (patch)
tree932fade6a5922dab441230b629d41b91fe7ee965
downloadaur-411d8d64d653bdf49cbc602743f353e014d64606.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
-rw-r--r--update-icon-cache.install14
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81769b12739f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vibrancy-colors
+ pkgdesc = A flat icon theme composed from many open source icon projects
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://www.ravefinity.com/p/vibrancy-colors-gtk-icon-theme.html
+ install = update-icon-cache.install
+ arch = any
+ groups = x11
+ license = custom:cc-by-sa-3.0
+ license = GPL2
+ options = !strip
+ options = !zipman
+ options = libtool
+ options = staticlibs
+ source = vibrancy-colors-2.2.1.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAMGFpYmFndjlDT00
+ md5sums = a2009301d42d2e3fe28983ecf0f05b05
+
+pkgname = vibrancy-colors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7ed8d550936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: ThePilot <afuturepilotis at gmail dot com>
+pkgname=vibrancy-colors
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="A flat icon theme composed from many open source icon projects"
+arch=('any')
+url="http://www.ravefinity.com/p/vibrancy-colors-gtk-icon-theme.html"
+license=('custom:cc-by-sa-3.0' 'GPL2')
+groups=('x11')
+options=('!strip' '!zipman' 'libtool' 'staticlibs')
+install=update-icon-cache.install
+source=($pkgname-$pkgver.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAMGFpYmFndjlDT00)
+md5sums=('a2009301d42d2e3fe28983ecf0f05b05')
+
+package() {
+ mkdir -p $pkgdir/usr/share/icons/
+ cp -r $srcdir/* $pkgdir/usr/share/icons/
+ mkdir -p $pkgdir/usr/share/licenses/vibrancy-colors/
+ mv "$pkgdir/usr/share/icons/Copyrights&Licenses.txt" "$pkgdir/usr/share/licenses/vibrancy-colors/"
+ rm "$pkgdir/usr/share/icons/README-Manual.txt" "$pkgdir/usr/share/icons/$pkgname-$pkgver.tar.gz"
+}
diff --git a/update-icon-cache.install b/update-icon-cache.install
new file mode 100644
index 000000000000..d576acaab137
--- /dev/null
+++ b/update-icon-cache.install
@@ -0,0 +1,14 @@
+post_install() {
+ for dir in usr/share/icons/Vibrancy*; do
+ gtk-update-icon-cache -ftq $dir
+ done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+