summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-06-10 08:44:51 +0200
committerSefa Eyeoglu2020-06-10 08:44:51 +0200
commit37c5b254ba869ac6cf50879359caf49eb04385c1 (patch)
treefd2eaf05e8ced04ce224b5a75ee4b0170b338c70
parent593d4d50310f95c7990f0dce8f94af7ab1b2fa67 (diff)
downloadaur-37c5b254ba869ac6cf50879359caf49eb04385c1.tar.gz
upgpkg: vibrant-git 1.0.3.r2.g8c5fa72-1
add check()
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67abbc68eac1..4b91a4bdb76a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vibrant-git
pkgdesc = A simple library to adjust color saturation of X11 outputs.
- pkgver = 0.0.2.r22.g3b880d2
+ pkgver = 1.0.3.r2.g8c5fa72
pkgrel = 1
url = https://gitlab.com/Scrumplex/vibrant
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = vibrant-git
license = custom:MIT
makedepends = git
makedepends = cmake
+ makedepends = check
source = vibrant-git::git+https://gitlab.com/Scrumplex/vibrant.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ceb703306f70..a0757335fb91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=vibrant-git
pkgname=(libvibrant-git vibrant-cli-git)
-pkgver=0.0.2.r22.g3b880d2
+pkgver=1.0.3.r2.g8c5fa72
pkgrel=1
pkgdesc="A simple library to adjust color saturation of X11 outputs."
arch=(x86_64)
url="https://gitlab.com/Scrumplex/vibrant"
license=("GPL3" "custom:MIT")
-makedepends=("git" "cmake")
+makedepends=("git" "cmake" "check")
source=("${pkgbase}::git+https://gitlab.com/Scrumplex/vibrant.git")
sha512sums=('SKIP')
@@ -28,6 +28,11 @@ build() {
make -C build
}
+check() {
+
+ make -C build test
+}
+
package_libvibrant-git() {
provides=("libvibrant" "libvibrant.so=1-64")
conflicts=("vibrant" "libvibrant")