summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-05-21 16:30:52 +0200
committerSefa Eyeoglu2020-05-21 16:30:52 +0200
commit488cf7ba91e507ce8cd34babcf12c33e8c819b04 (patch)
tree2f5fd19bd211a688a9047e44916ccd7781dcfeaa
parentff89c38674d4f544e6acaa5c1bbb0d3f01c25bfa (diff)
downloadaur-488cf7ba91e507ce8cd34babcf12c33e8c819b04.tar.gz
vibrantlinux: initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21df66c66dc9..97ef3fa1be5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
-pkgbase = vibrantlinux-amd-git
+pkgbase = vibrantlinux
pkgdesc = vibranceGUI replacement for Linux (AMD only)
- pkgver = 1.2.5.r1.g4ed73ef
+ pkgver = 2.0.0
pkgrel = 1
- url = https://github.com/Scrumplex/vibrantLinux-AMD
+ url = https://github.com/zee-mzha/vibrantLinux
arch = x86_64
license = MIT
makedepends = git
- depends = vibrantx
depends = qt5-base
- provides = vibrantlinux-git
+ depends = libxnvctrl
+ depends = vibrant
+ depends = libxrandr
provides = vibrantlinux
- conflicts = vibrantlinux-git
conflicts = vibrantlinux
- source = vibrantlinux-amd::git+https://github.com/Scrumplex/vibrantLinux-AMD.git
+ source = vibrantlinux::git+https://github.com/zee-mzha/vibrantLinux.git
source = vibrantLinux.desktop
sha512sums = SKIP
sha512sums = 21531277bbcea2ab65116f8420db9197f99801f34f934f9bd181fb2077c3c26337c7356df236783a53eee6dccc3e994f7992c9aaa8d53ca32ec0d98231357b1f
-pkgname = vibrantlinux-amd-git
+pkgname = vibrantlinux
diff --git a/PKGBUILD b/PKGBUILD
index a23c5d871525..17a71c3665cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,24 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
# Container: gbr <gbr@protonmail.com>
-_pkgname=vibrantlinux-amd
-pkgname=${_pkgname}-git
-pkgver=1.2.5.r1.g4ed73ef
+_pkgname=vibrantlinux
+pkgname=${_pkgname}
+pkgver=2.0.0
pkgrel=1
pkgdesc='vibranceGUI replacement for Linux (AMD only)'
arch=(x86_64)
-url="https://github.com/Scrumplex/vibrantLinux-AMD"
+url="https://github.com/zee-mzha/vibrantLinux"
license=('MIT')
-depends=('vibrantx' 'qt5-base')
-makedepends=('git')
-conflicts=("vibrantlinux-git" "vibrantlinux")
-provides=("vibrantlinux-git" "vibrantlinux")
-source=("${_pkgname}::git+https://github.com/Scrumplex/vibrantLinux-AMD.git"
+depends=("qt5-base" "libxnvctrl" "vibrant" "libxrandr")
+makedepends=("git")
+conflicts=("vibrantlinux")
+provides=("vibrantlinux")
+source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git"
"vibrantLinux.desktop")
sha512sums=('SKIP'
'21531277bbcea2ab65116f8420db9197f99801f34f934f9bd181fb2077c3c26337c7356df236783a53eee6dccc3e994f7992c9aaa8d53ca32ec0d98231357b1f')
-pkgver() {
- cd "${_pkgname}"
-
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
cd "${_pkgname}"