summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2024-05-10 21:42:24 +0200
committerSefa Eyeoglu2024-05-10 21:42:24 +0200
commitd163b37ec49d2e84898b76f454e8056b80d45dd1 (patch)
treedd8c35488b65f0877cb5de6468d9e72e1dec70de
parent00f7a8b8d16a8c35a961e099a1a65f6789bc9202 (diff)
downloadaur-d163b37ec49d2e84898b76f454e8056b80d45dd1.tar.gz
vibrantlinux: 2.1.10 -> 2.2.0
Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be966adaafa9..f82b821b078d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = vibrantlinux
pkgdesc = A tool to automate managing your screen's saturation depending on what programs are running
- pkgver = 2.1.10
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/libvibrant/vibrantLinux
arch = x86_64
- license = MIT
+ license = GPL
makedepends = git
- depends = qt5-base
+ makedepends = cmake
+ depends = qt6-base
depends = libvibrant
- source = vibrantlinux::git+https://github.com/libvibrant/vibrantLinux.git#tag=v2.1.10
- sha512sums = SKIP
+ source = vibrantLinux-2.2.0.tar.gz::https://github.com/libvibrant/vibrantLinux/archive/refs/tags/v2.2.0.tar.gz
+ b2sums = 845f4bd44e3c9d6ff033f1a98f6bcb8c8144c6d965938f55e18497955c964b6988483129d39a1c56e5cf3a50d0066c3ed25f407d327f860c7cb3c978de4843d1
pkgname = vibrantlinux
diff --git a/PKGBUILD b/PKGBUILD
index 105ff59e260e..bf91bb87367f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,29 @@
# Container: gbr <gbr@protonmail.com>
pkgname=vibrantlinux
-pkgver=2.1.10
+_pkgname=vibrantLinux
+pkgver=2.2.0
pkgrel=1
pkgdesc="A tool to automate managing your screen's saturation depending on what programs are running"
arch=(x86_64)
url="https://github.com/libvibrant/vibrantLinux"
-license=('MIT')
-depends=("qt5-base" "libvibrant")
-makedepends=("git")
-source=("${pkgname}::git+https://github.com/libvibrant/vibrantLinux.git#tag=v${pkgver}")
-sha512sums=('SKIP')
-
+license=('GPL')
+depends=("qt6-base" "libvibrant")
+makedepends=("git" "cmake")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/libvibrant/vibrantLinux/archive/refs/tags/v${pkgver}.tar.gz")
+b2sums=('845f4bd44e3c9d6ff033f1a98f6bcb8c8144c6d965938f55e18497955c964b6988483129d39a1c56e5cf3a50d0066c3ed25f407d327f860c7cb3c978de4843d1')
build() {
- cd "${pkgname}"
-
- qmake
- make ${MAKEFLAGS}
+ cd "${_pkgname}-${pkgver}"
+ cmake -DCMAKE_BUILD_TYPE= \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -Bbuild -S.
+ cmake --build build
}
package() {
- cd "${pkgname}"
-
- make INSTALL_ROOT="${pkgdir}" install
-
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ cd "${_pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" cmake --install build
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}