summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgbr2022-01-01 21:32:15 -0300
committergbr2022-01-01 21:32:15 -0300
commit8e00dea925e77eb047771e5d0002d8aead4207b4 (patch)
treeaeb9579b97348870a6145706d935fa3ccb77613b
parentbd9eda06dabb23b25eefe34872e4e385d8ef981f (diff)
downloadaur-8e00dea925e77eb047771e5d0002d8aead4207b4.tar.gz
fix build, general cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5236e1b447b5..5841d7e0088a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = vibrantlinux-git
pkgdesc = vibranceGUI replacement for Linux
- pkgver = 2.1.1.r10.g3ddb88f
+ pkgver = 2.1.7.r0.ga75092b
pkgrel = 1
- url = https://github.com/zee-mzha/vibrantlinux
+ url = https://github.com/libvibrant/vibrantlinux
arch = x86_64
license = MIT
makedepends = git
@@ -10,8 +10,7 @@ pkgbase = vibrantlinux-git
depends = libvibrant
provides = vibrantlinux
conflicts = vibrantlinux
- source = vibrantlinux::git+https://github.com/zee-mzha/vibrantLinux.git
+ source = vibrantlinux::git+https://github.com/libvibrant/vibrantlinux.git
sha256sums = SKIP
pkgname = vibrantlinux-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a32f15c0be4..837f03823494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,28 @@ pkgname=vibrantlinux-git
pkgrel=1
pkgdesc='vibranceGUI replacement for Linux'
arch=('x86_64')
-url='https://github.com/zee-mzha/vibrantlinux'
+url='https://github.com/libvibrant/vibrantlinux'
license=('MIT')
depends=('qt5-base' 'libvibrant')
makedepends=('git')
conflicts=('vibrantlinux')
provides=('vibrantlinux')
-source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git")
+source=("$_pkgname::git+$url.git")
sha256sums=('SKIP')
-pkgver=2.1.1.r10.g3ddb88f
+pkgver=2.1.7.r0.ga75092b
pkgver() {
- cd "${_pkgname}"
-
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_pkgname}"
-
- qmake
- make
+ cd "$_pkgname"
+ qmake
+ make
}
package() {
- cd "${_pkgname}"
-
- make INSTALL_ROOT="${pkgdir}" install
-
- mv "${pkgdir}/usr/share/applications/application.desktop" "${pkgdir}/usr/share/applications/vibrantLinux.desktop"
+ cd "$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
}