summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgbr2019-02-06 20:35:12 -0200
committergbr2019-02-06 20:37:37 -0200
commitc88e6efa6d8345f4c3945ed0db65b5149dcbde05 (patch)
treec5f8d7f201a459ddc4b372ef5b98a3cb9c4cbb2c
downloadaur-c88e6efa6d8345f4c3945ed0db65b5149dcbde05.tar.gz
vibrantLinux r12.8f1a430
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
-rw-r--r--vibrantLinux.desktop10
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f24daee9a357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vibrantlinux-git
+ pkgdesc = vibranceGUI replacement for Linux (NVIDIA only)
+ pkgver = r12.8f1a430
+ pkgrel = 1
+ url = https://gitlab.com/zee220/vibrantlinux
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = imagemagick
+ depends = nvidia-settings
+ depends = qt5-base
+ source = vibrantlinux::git+https://gitlab.com/zee220/vibrantlinux.git
+ source = vibrantLinux.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = vibrantlinux-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4faf0ce8d4d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: gbr <gbr@protonmail.com>
+_pkgname=vibrantlinux
+pkgname=vibrantlinux-git
+pkgrel=1
+pkgdesc='vibranceGUI replacement for Linux (NVIDIA only)'
+arch=('x86_64' 'i686')
+url='https://gitlab.com/zee220/vibrantlinux'
+license=('MIT')
+depends=('nvidia-settings'
+ 'qt5-base')
+makedepends=('git'
+ 'imagemagick')
+conflicts=()
+source=("$_pkgname::git+$url.git"
+ 'vibrantLinux.desktop')
+sha256sums=('SKIP'
+ 'SKIP')
+pkgver=r12.8f1a430
+
+pkgver()
+{
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "$_pkgname"
+ qmake
+ make $MAKEFLAGS
+}
+
+package()
+{
+ cd "$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/vibrantLinux/bin/vibrantLinux" "$pkgdir/usr/bin"
+ install -Dm644 "$srcdir/vibrantLinux.desktop" "$pkgdir/usr/share/applications/vibrantLinux.desktop"
+
+ convert 'assets/icon.png' -resize '512x512' 'assets/icon512.png'
+ install -Dm664 'assets/icon512.png' "$pkgdir/usr/share/icons/hicolor/512x512/apps/vibrantLinux.png"
+
+ install -Dm664 'assets/icon512.png' "$pkgdir/opt/vibrantLinux/bin/assets/icon.png"
+}
diff --git a/vibrantLinux.desktop b/vibrantLinux.desktop
new file mode 100644
index 000000000000..1201591b278b
--- /dev/null
+++ b/vibrantLinux.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Vibrant Linux
+GenericName=Digital vibrance controller
+Comment=Program-specific digital vibrance controller
+Exec=vibrantLinux
+Icon=vibrantLinux
+Terminal=false
+Type=Application
+Categories=Utility;