summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgbr2020-06-02 18:55:48 -0300
committergbr2020-06-02 18:55:48 -0300
commitfd40d89306af6fffe232d33cd6d438fe10ab83b9 (patch)
tree80c9e5fd4dc843af886cdb4a9fbcaab885cfa1ee
parente85efcc0bf46486faf7d6b5eb011f8979b615512 (diff)
downloadaur-fd40d89306af6fffe232d33cd6d438fe10ab83b9.tar.gz
Revert icons workaround
I'd rather install properly resized icons under /usr/share/icons/hicolor, as per the Free Desktop Specification[1]: "In order to have a place for third party applications to install their icons there should always exist a theme called "hicolor" But since the current upstream solution doesn't seem to violate the standard either, I'm respecting their choice to install a single icon to /usr/share/pixmaps. [1] https://specifications.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#directory_layout
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 3 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e48ac3dd95ac..5236e1b447b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = vibrantlinux-git
pkgdesc = vibranceGUI replacement for Linux
- pkgver = 2.1.1.r7.g1dc6b43
+ pkgver = 2.1.1.r10.g3ddb88f
pkgrel = 1
url = https://github.com/zee-mzha/vibrantlinux
arch = x86_64
license = MIT
makedepends = git
- makedepends = imagemagick
depends = qt5-base
depends = libvibrant
provides = vibrantlinux
diff --git a/PKGBUILD b/PKGBUILD
index 94627558eb55..1a32f15c0be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@ arch=('x86_64')
url='https://github.com/zee-mzha/vibrantlinux'
license=('MIT')
depends=('qt5-base' 'libvibrant')
-makedepends=('git' 'imagemagick')
+makedepends=('git')
conflicts=('vibrantlinux')
provides=('vibrantlinux')
source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git")
sha256sums=('SKIP')
-pkgver=2.1.1.r7.g1dc6b43
+pkgver=2.1.1.r10.g3ddb88f
pkgver() {
cd "${_pkgname}"
@@ -32,11 +32,5 @@ package() {
make INSTALL_ROOT="${pkgdir}" install
- for res in 16 32 64 128 256 512; do
- convert "${srcdir}/vibrantlinux/assets/icon.png" -resize "${res}x${res}" "${srcdir}/vibrantlinux/assets/icon-${res}.png"
- install -Dm644 "${srcdir}/vibrantlinux/assets/icon-${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vibrantLinux.png"
- done
-
- rm "${pkgdir}/usr/share/icons/icon.png"
mv "${pkgdir}/usr/share/applications/application.desktop" "${pkgdir}/usr/share/applications/vibrantLinux.desktop"
}