summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2016-10-26 14:32:29 +0200
committerSebastian Wolf2016-10-26 14:33:02 +0200
commit96f31262208b3df9994240f0fc0cd630bc743889 (patch)
tree82b94099ea0126a76813786f701e47654b17e7f6
downloadaur-96f31262208b3df9994240f0fc0cd630bc743889.tar.gz
Initial commit
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD46
-rw-r--r--no-fc-cache-no-lib64.patch76
-rw-r--r--vice.desktop10
-rwxr-xr-xvice.pngbin0 -> 2088 bytes
5 files changed, 172 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c289a30393c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Wed Oct 26 12:30:45 UTC 2016
+pkgbase = vice-sdl-devel
+ pkgdesc = The Versatile Commodore 8-bit Emulator (development release using SDL)
+ pkgver = 2.4.31
+ pkgrel = 1
+ url = http://vice-emu.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = xorg-font-utils
+ depends = sdl
+ depends = libpulse
+ depends = portaudio
+ depends = mpg123
+ depends = mesa
+ depends = pciutils
+ depends = giflib
+ depends = libpng
+ depends = libpcap
+ depends = libjpeg-turbo
+ provides = vice=$pkgver
+ conflicts = vice
+ conflicts = vice-gtk
+ conflicts = vice-sdl
+ conflicts = vice-gtkglext
+ conflicts = vice-gnomeui-devel
+ replaces = vice
+ options = !makeflags
+ source = http://downloads.sourceforge.net/project/vice-emu/development-releases/vice-2.4.31.tar.gz
+ source = no-fc-cache-no-lib64.patch
+ source = vice.desktop
+ source = vice.png
+ sha256sums = 4c38685de5f492463cf1b0a570909bfba0dc5c2ffab3218081b630a47118f4a5
+ sha256sums = b0254ac814918d76c60d0130f0e8e874c71aaf77e979a36c6a67dbbf7322cbb5
+ sha256sums = e0a600d72c2352826282a0f7fcf380b24272fba10a9ed31c8fd45a21d597f3ad
+ sha256sums = 0d51f822b70d24bbc9d813d552138660cf705aaaecc12115bc1416364e1473b3
+
+pkgname = vice-sdl-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a20fb771465
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sebastian Wolf <fatmike303 at gmail dot com>
+# Contributor: grimi <grimi at poczta dot fm>
+pkgname=vice-sdl-devel
+_pkgname=vice
+pkgver=2.4.31
+pkgrel=1
+pkgdesc='The Versatile Commodore 8-bit Emulator (development release using SDL)'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://vice-emu.sourceforge.net'
+depends=('sdl' 'libpulse' 'portaudio' 'mpg123' 'mesa' 'pciutils' 'giflib' 'libpng' 'libpcap' 'libjpeg-turbo')
+makedepends=('xorg-font-utils')
+provides=('vice=$pkgver')
+conflicts=('vice' 'vice-gtk' 'vice-sdl' 'vice-gtkglext' 'vice-gnomeui-devel')
+replaces=('vice')
+options=('!makeflags')
+source=(
+ http://downloads.sourceforge.net/project/vice-emu/development-releases/${_pkgname}-${pkgver}.tar.gz
+ no-fc-cache-no-lib64.patch
+ ${_pkgname}.desktop
+ ${_pkgname}.png
+)
+sha256sums=(
+ 4c38685de5f492463cf1b0a570909bfba0dc5c2ffab3218081b630a47118f4a5
+ b0254ac814918d76c60d0130f0e8e874c71aaf77e979a36c6a67dbbf7322cbb5
+ e0a600d72c2352826282a0f7fcf380b24272fba10a9ed31c8fd45a21d597f3ad
+ 0d51f822b70d24bbc9d813d552138660cf705aaaecc12115bc1416364e1473b3
+)
+
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ patch -Np1 -i ../no-fc-cache-no-lib64.patch
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ ./configure --prefix=/usr --enable-fullscreen --enable-sdlui --with-sdlsound --enable-ethernet
+ make
+}
+
+package() {
+ install -Dm644 ${_pkgname}.desktop $pkgdir/usr/share/applications/${_pkgname}.desktop
+ install -Dm644 ${_pkgname}.png $pkgdir/usr/share/pixmaps/${_pkgname}.png
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/no-fc-cache-no-lib64.patch b/no-fc-cache-no-lib64.patch
new file mode 100644
index 000000000000..466251658c27
--- /dev/null
+++ b/no-fc-cache-no-lib64.patch
@@ -0,0 +1,76 @@
+diff --git a/configure b/configure
+index c5f25a4..6c15e46 100755
+--- a/configure
++++ b/configure
+@@ -19813,7 +19813,7 @@ _ACEOF
+ *) test -f "$ac_im_incroot/X11/Xos.h" && ac_x_includes=$ac_im_incroot;;
+ esac
+ case $ac_im_usrlibdir in
+- /usr/lib | /usr/lib64 | /lib | /lib64) ;;
++ /usr/lib | /usr/lib | /lib | /lib) ;;
+ *) test -d "$ac_im_usrlibdir" && ac_x_libraries=$ac_im_usrlibdir ;;
+ esac
+ fi
+@@ -24802,7 +24802,7 @@ fi
+ ;;
+ linux*)
+ if test x"$host_cpu" = "xx86_64"; then
+- VICEDIR="$PREFIX/lib64/vice"
++ VICEDIR="$PREFIX/lib/vice"
+ if false; then
+ ALTERNATE_DOCDIR_TRUE=
+ ALTERNATE_DOCDIR_FALSE='#'
+diff --git a/configure.ac b/configure.ac
+index 73f5b22..842e246 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -2954,12 +2954,7 @@ if test x"$enable_lame" != "xno" ; then
+
+ fi
+
+-AC_PATH_PROGS(FCCACHE, fc-cache, false)
+-if test x"$FCCACHE" = "xfalse"; then
+- AM_CONDITIONAL(HAVE_FC_CACHE, false)
+-else
+- AM_CONDITIONAL(HAVE_FC_CACHE, true)
+-fi
++AM_CONDITIONAL(HAVE_FC_CACHE, false)
+
+ if test x"$is_amigaos4" = "xyes"; then
+ if test x"$enable_sdlui" != "xyes" -a x"$enable_sdlui2" != "xyes"; then
+@@ -4636,7 +4631,7 @@ case "$host_os" in
+ ;;
+ linux*)
+ if test x"$host_cpu" = "xx86_64"; then
+- VICEDIR="$PREFIX/lib64/vice"
++ VICEDIR="$PREFIX/lib/vice"
+ AM_CONDITIONAL(ALTERNATE_DOCDIR, false)
+ else
+ VICEDIR="$PREFIX/lib/vice"
+diff --git a/configure.proto b/configure.proto
+index 73f5b22..842e246 100755
+--- a/configure.proto
++++ b/configure.proto
+@@ -2954,12 +2954,7 @@ if test x"$enable_lame" != "xno" ; then
+
+ fi
+
+-AC_PATH_PROGS(FCCACHE, fc-cache, false)
+-if test x"$FCCACHE" = "xfalse"; then
+- AM_CONDITIONAL(HAVE_FC_CACHE, false)
+-else
+- AM_CONDITIONAL(HAVE_FC_CACHE, true)
+-fi
++AM_CONDITIONAL(HAVE_FC_CACHE, false)
+
+ if test x"$is_amigaos4" = "xyes"; then
+ if test x"$enable_sdlui" != "xyes" -a x"$enable_sdlui2" != "xyes"; then
+@@ -4636,7 +4631,7 @@ case "$host_os" in
+ ;;
+ linux*)
+ if test x"$host_cpu" = "xx86_64"; then
+- VICEDIR="$PREFIX/lib64/vice"
++ VICEDIR="$PREFIX/lib/vice"
+ AM_CONDITIONAL(ALTERNATE_DOCDIR, false)
+ else
+ VICEDIR="$PREFIX/lib/vice"
diff --git a/vice.desktop b/vice.desktop
new file mode 100644
index 000000000000..1bc5bf64318f
--- /dev/null
+++ b/vice.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=VICE: C64 Emulator
+Comment=Commodore 64 Emulator
+Exec=x64
+Icon=vice
+Terminal=false
+StartupNotify=false
+Categories=Game;
diff --git a/vice.png b/vice.png
new file mode 100755
index 000000000000..44249cadeb48
--- /dev/null
+++ b/vice.png
Binary files differ