summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2020-07-25 05:46:24 +0200
committerFrederic Bezies2020-07-25 05:46:24 +0200
commit8e5f4ec45eb8ea7c89a37f6520a2a1a7ba0239fc (patch)
treec7cc8a4266f3cd131334a5d009a0ab67e4778ea3
parentb63a1ed170c0d889abc30da5cb82f9239216f344 (diff)
downloadaur-8e5f4ec45eb8ea7c89a37f6520a2a1a7ba0239fc.tar.gz
July 25th, 2020 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--vice-fixes.patch27
3 files changed, 26 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a819fa66752..a66ba4bac5f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = vice-svn
- pkgdesc = The Versatile Commodore Emulator (Commodore 64/C64).
- pkgver = r34920
+ pkgdesc = The Versatile Commodore Emulator (Commodore 64/C64). - Development version
+ pkgver = r38195
pkgrel = 1
url = http://vice-emu.sourceforge.net
arch = i686
arch = x86_64
license = GPL
- makedepends = xorg-font-utils
makedepends = pkg-config
+ makedepends = xa
+ makedepends = svn
+ makedepends = texlive-core
+ makedepends = dos2unix
depends = giflib
depends = lame
depends = libjpeg
@@ -20,11 +23,12 @@ pkgbase = vice-svn
optdepends = pulseaudio-alsa
optdepends = alsa-lib
provides = vice
+ conflicts = vice-sdl2
+ conflicts = vice-svn-gtk3
+ conflicts = vice-svn-sdl2
replaces = vice
source = vice-svn::svn://svn.code.sf.net/p/vice-emu/code/trunk
- source = vice-fixes.patch
- md5sums = SKIP
- md5sums = 6ae696148e372bcdc7aa21e4fc39e5d2
+ sha256sums = SKIP
pkgname = vice-svn
diff --git a/PKGBUILD b/PKGBUILD
index 9fd6d17344ee..09869aaaffcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Benjamin Hodgetts <ben@xnode.org>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Benjamin Hodgetts <ben@xnode.org>
pkgname=vice-svn
-pkgver=r34920
+pkgver=r38195
pkgrel=1
-pkgdesc="The Versatile Commodore Emulator (Commodore 64/C64)."
+pkgdesc="The Versatile Commodore Emulator (Commodore 64/C64). - Development version"
arch=('i686' 'x86_64')
url="http://vice-emu.sourceforge.net"
license=('GPL')
depends=('giflib' 'lame' 'libjpeg' 'libpng' 'libxrandr' 'libnet' 'libpcap' 'xdialog')
-makedepends=('xorg-font-utils' 'pkg-config')
+makedepends=('pkg-config' 'xa' 'svn' 'texlive-core' 'dos2unix')
optdepends=('pulseaudio' 'pulseaudio-alsa' 'alsa-lib')
provides=('vice')
replaces=('vice')
-source=("${pkgname}::svn://svn.code.sf.net/p/vice-emu/code/trunk" 'vice-fixes.patch')
-md5sums=('SKIP' '6ae696148e372bcdc7aa21e4fc39e5d2')
+conflicts=('vice-sdl2' 'vice-svn-gtk3' 'vice-svn-sdl2')
+source=("${pkgname}::svn://svn.code.sf.net/p/vice-emu/code/trunk")
+sha256sums=('SKIP')
pkgver() {
echo r$(svnversion "${SRCDEST}"/${pkgname}/)
}
-prepare() {
- cd "${pkgname}/vice"
- patch -Np1 -i ../../vice-fixes.patch
-}
-
build() {
- cd "${pkgname}/vice"
- ./autogen.sh
- ./configure --prefix=/usr --without-oss --without-alsa --enable-native-gtk3ui
- make
+ cd "${pkgname}/vice"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --enable-external-ffmpeg \
+ --enable-x64
+ make
}
package() {
diff --git a/vice-fixes.patch b/vice-fixes.patch
deleted file mode 100644
index c11035fff0c6..000000000000
--- a/vice-fixes.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/configure.proto 2011-02-19 23:07:05.000000000 +0100
-+++ b/configure.proto 2012-08-06 13:18:46.000000000 +0200
-@@ -1990,12 +1990,7 @@
-
- fi
-
--AC_PATH_PROGS(FCCACHE, fc-cache, false)
--if test x"$FCCACHE" = "xfalse"; then
- AM_CONDITIONAL(HAVE_FC_CACHE, false)
--else
-- AM_CONDITIONAL(HAVE_FC_CACHE, true)
--fi
-
- if test x"$is_amigaos4" = "xyes"; then
- if test x"$enable_sdlui" != "xyes"; then
-
---- a/configure.proto 2012-11-01 16:37:51.000000000 +0100
-+++ b/configure.proto 2012-11-03 18:07:35.000000000 +0100
-@@ -3424,7 +3419,7 @@
- ;;
- linux*)
- if test x"$host_cpu" = "xx86_64"; then
-- VICEDIR="$PREFIX/lib64/vice"
-+ VICEDIR="$PREFIX/lib/vice"
- AM_CONDITIONAL(ALTERNATE_DOCDIR, false)
- else
- VICEDIR="$PREFIX/lib/vice"