summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Hodgetts2018-04-23 09:13:16 +0100
committerBenjamin Hodgetts2018-04-23 09:13:16 +0100
commitacc36e5680f283ca29ac558082d6518a6ee85a4a (patch)
treea5197f9cce7978a1701e09d26122943650caa0bc
downloadaur-acc36e5680f283ca29ac558082d6518a6ee85a4a.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD37
-rw-r--r--vice-fixes.patch27
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a68242aa0bf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = vice-svn
+ pkgdesc = The Versatile Commodore Emulator (Commodore 64/C64).
+ pkgver = r34716
+ pkgrel = 1
+ url = http://vice-emu.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = xorg-font-utils
+ makedepends = pkg-config
+ depends = giflib
+ depends = lame
+ depends = libjpeg
+ depends = libpng
+ depends = libxrandr
+ depends = libnet
+ depends = libpcap
+ depends = vte
+ depends = xdialog
+ optdepends = pulseaudio
+ optdepends = pulseaudio-alsa
+ optdepends = alsa-lib
+ provides = vice
+ replaces = vice
+ source = vice-svn::svn://svn.code.sf.net/p/vice-emu/code/trunk
+ source = vice-fixes.patch
+ md5sums = SKIP
+ md5sums = 6ae696148e372bcdc7aa21e4fc39e5d2
+
+pkgname = vice-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65df292f18c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Benjamin Hodgetts <ben@xnode.org>
+
+pkgname=vice-svn
+pkgver=r34716
+pkgrel=1
+pkgdesc="The Versatile Commodore Emulator (Commodore 64/C64)."
+arch=('i686' 'x86_64')
+url="http://vice-emu.sourceforge.net"
+license=('GPL')
+depends=('giflib' 'lame' 'libjpeg' 'libpng' 'libxrandr' 'libnet' 'libpcap' 'vte' 'xdialog')
+makedepends=('xorg-font-utils' 'pkg-config')
+optdepends=('pulseaudio' 'pulseaudio-alsa' 'alsa-lib')
+provides=('vice')
+replaces=('vice')
+source=("${pkgname}::svn://svn.code.sf.net/p/vice-emu/code/trunk" 'vice-fixes.patch')
+md5sums=('SKIP' '6ae696148e372bcdc7aa21e4fc39e5d2')
+
+pkgver() {
+ echo r$(svnversion "${SRCDEST}"/${pkgname}/)
+}
+
+prepare() {
+ cd "${pkgname}/vice"
+ patch -Np1 -i ../../vice-fixes.patch
+}
+
+build() {
+ cd "${pkgname}/vice"
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-fullscreen --without-oss --with-pulse --without-alsa --enable-gnomeui
+ make
+}
+
+package() {
+ cd "${pkgname}/vice"
+ make install DESTDIR="${pkgdir}/"
+}
diff --git a/vice-fixes.patch b/vice-fixes.patch
new file mode 100644
index 000000000000..c11035fff0c6
--- /dev/null
+++ b/vice-fixes.patch
@@ -0,0 +1,27 @@
+--- a/configure.proto 2011-02-19 23:07:05.000000000 +0100
++++ b/configure.proto 2012-08-06 13:18:46.000000000 +0200
+@@ -1990,12 +1990,7 @@
+
+ fi
+
+-AC_PATH_PROGS(FCCACHE, fc-cache, false)
+-if test x"$FCCACHE" = "xfalse"; then
+ AM_CONDITIONAL(HAVE_FC_CACHE, false)
+-else
+- AM_CONDITIONAL(HAVE_FC_CACHE, true)
+-fi
+
+ if test x"$is_amigaos4" = "xyes"; then
+ if test x"$enable_sdlui" != "xyes"; then
+
+--- a/configure.proto 2012-11-01 16:37:51.000000000 +0100
++++ b/configure.proto 2012-11-03 18:07:35.000000000 +0100
+@@ -3424,7 +3419,7 @@
+ ;;
+ linux*)
+ if test x"$host_cpu" = "xx86_64"; then
+- VICEDIR="$PREFIX/lib64/vice"
++ VICEDIR="$PREFIX/lib/vice"
+ AM_CONDITIONAL(ALTERNATE_DOCDIR, false)
+ else
+ VICEDIR="$PREFIX/lib/vice"