summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2020-07-07 19:01:57 +0200
committerFrederic Bezies2020-07-07 19:01:57 +0200
commit254fe4e2fd207041fa710a128a279980a7e73016 (patch)
treec2846f792d3f04f729397e2b3bc9549fc6e845ea
downloadaur-254fe4e2fd207041fa710a128a279980a7e73016.tar.gz
initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD42
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe077d4df415
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = vice-svn-sdl2
+ pkgdesc = The Versatile Commodore Emulator (Commodore 64/C64) - SDL2 development version
+ pkgver = r38079
+ pkgrel = 1
+ url = http://vice-emu.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = xa
+ makedepends = svn
+ depends = giflib
+ depends = lame
+ depends = libjpeg
+ depends = libpng
+ depends = libxrandr
+ depends = libnet
+ depends = libpcap
+ depends = xdialog
+ optdepends = pulseaudio
+ optdepends = pulseaudio-alsa
+ optdepends = alsa-lib
+ provides = vice
+ conflicts = vice
+ conflicts = vice-svn
+ replaces = vice
+ source = vice-svn::svn://svn.code.sf.net/p/vice-emu/code/trunk
+ sha256sums = SKIP
+
+pkgname = vice-svn-sdl2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc993a8fb226
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Based on vice-svn PKGBUILD by Benjamin Hodgetts <ben@xnode.org>
+
+pkgname=vice-svn-sdl2
+_pkgname=vice-svn
+pkgver=r38079
+pkgrel=1
+pkgdesc="The Versatile Commodore Emulator (Commodore 64/C64) - SDL2 development version"
+arch=('i686' 'x86_64')
+url="http://vice-emu.sourceforge.net"
+license=('GPL')
+depends=('giflib' 'lame' 'libjpeg' 'libpng' 'libxrandr' 'libnet' 'libpcap' 'xdialog')
+makedepends=('pkg-config' 'xa' 'svn')
+optdepends=('pulseaudio' 'pulseaudio-alsa' 'alsa-lib')
+provides=('vice')
+replaces=('vice')
+conflicts=('vice' 'vice-svn')
+source=("${_pkgname}::svn://svn.code.sf.net/p/vice-emu/code/trunk")
+sha256sums=('SKIP')
+
+pkgver() {
+ echo r$(svnversion "${SRCDEST}"/${_pkgname}/)
+}
+
+build() {
+# Docs are disabled until further update.
+ cd "${_pkgname}/vice"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --enable-external-ffmpeg \
+ --enable-x64 \
+ --enable-sdlui2 \
+ --disable-pdf-docs
+ make
+}
+
+package() {
+ cd "${_pkgname}/vice"
+ make install DESTDIR="${pkgdir}/"
+}