summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2017-03-30 22:29:24 -0600
committerBrian Bidulock2017-03-30 22:29:24 -0600
commit00d8d6eacea006a9c8cc0eb00152cdbf92c07cb0 (patch)
tree55bcfa4b634ad7b611e0ac3c0298c72048e00c19
parent379361ba788f6762cef826d497f0ed2a96fdd0b9 (diff)
downloadaur-00d8d6eacea006a9c8cc0eb00152cdbf92c07cb0.tar.gz
version 2.1.3.9.g02e1142-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD86
-rw-r--r--vicious-git.install23
3 files changed, 33 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84da36f94746..65e9a252b6f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = vicious-git
- pkgdesc = Modular widget library for window managers
- pkgver = 2.1.3.9.g02e1142
- pkgrel = 2
+ pkgdesc = Widgets for the Awesome window manager
+ pkgver = 2.1.1.207.g4c082ac
+ pkgrel = 1
url = http://git.sysphere.org/vicious/about/
- install = vicious-git.install
arch = any
license = GPL2
makedepends = git
depends = lua
- optdepends = awesome: for which vicious was mainly written for
optdepends = hddtemp: for the HDD Temp widget type
optdepends = alsa-utils: for the Volume widget type
optdepends = wireless_tools: for the Wireless widget type
@@ -16,7 +14,7 @@ pkgbase = vicious-git
provides = vicious
conflicts = vicious
source = vicious-git::git+http://git.sysphere.org/vicious
- sha1sums = SKIP
+ md5sums = SKIP
pkgname = vicious-git
diff --git a/PKGBUILD b/PKGBUILD
index f4a35d2589a7..9cd20cce858f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,40 @@
-# -*- shell-script -*-
-#
+# Maintianer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Adrian C. <anrxc..sysphere.org>
pkgname=vicious-git
-_gitname=vicious
-pkgver=2.1.3.9.g02e1142
-_luaver="5.3"
-pkgrel=2
-pkgdesc="Modular widget library for window managers"
-arch=("any")
-url="http://git.sysphere.org/vicious/about/"
-license=("GPL2")
-depends=("lua")
-makedepends=("git")
-optdepends=("awesome: for which vicious was mainly written for"
- "hddtemp: for the HDD Temp widget type"
- "alsa-utils: for the Volume widget type"
- "wireless_tools: for the Wireless widget type"
- "curl: for widget types accessing network resources")
-provides=("vicious")
-conflicts=("vicious")
-install="${pkgname}.install"
-source=(${pkgname}::git+http://git.sysphere.org/${_gitname})
-sha1sums=("SKIP")
+_pkgname=vicious
+pkgver=2.1.1.207.g4c082ac
+pkgrel=1
+pkgdesc='Widgets for the Awesome window manager'
+arch=('any')
+url='http://git.sysphere.org/vicious/about/'
+license=('GPL2')
+depends=('lua')
+makedepends=('git')
+optdepends=(
+ 'hddtemp: for the HDD Temp widget type'
+ 'alsa-utils: for the Volume widget type'
+ 'wireless_tools: for the Wireless widget type'
+ 'curl: for widget types accessing network resources'
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=(${pkgname}::git+http://git.sysphere.org/${_pkgname})
+md5sums=('SKIP')
pkgver() {
- cd "${pkgname}"
-
-# git describe --always | sed 's|-|.|g'
+ cd $pkgname
git describe --always | sed 's|^[^0-9]*||;s|\.g[a-f0-9]*$||;s|-|.|g'
}
-
-build() {
- cd "${pkgname}"
-
-# Download or update the library
-# - automatic since pacman v4.1
-}
-
-
package () {
- cd "${pkgname}"
-
-# Install the vicious library
- install -d "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}"
- install -m644 *.lua "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}"
-
-# Install vicious widgets
- install -d "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/widgets"
- install -m644 widgets/*.lua "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/widgets"
-
-# Install user contributed widgets
- install -d "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/contrib"
- install -m644 contrib/*.lua "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/contrib"
-
-# Install support for legacy lua51
- install -d "${pkgdir}/usr/share/lua/5.1"
- ln -s /usr/share/lua/${_luaver}/vicious ${pkgdir}/usr/share/lua/5.1/vicious
-
-# Install the documentation
- install -D -m644 CHANGES "${pkgdir}/usr/share/doc/${_gitname}/CHANGES"
- install -m644 TODO "${pkgdir}/usr/share/doc/${_gitname}"
- install -m644 README "${pkgdir}/usr/share/doc/${_gitname}"
- install -m644 LICENSE "${pkgdir}/usr/share/doc/${_gitname}"
+ cd $pkgname
+ # Install the vicious library
+ install -dm755 "$pkgdir"/usr/share/lua/5.3/$pkgname/{widgets,contrib}
+ install -m644 *.lua "$pkgdir/usr/share/lua/5.3/$pkgname"
+ install -m644 widgets/*.lua "$pkgdir/usr/share/lua/5.3/$pkgname/widgets"
+ install -m644 contrib/*.lua "$pkgdir/usr/share/lua/5.3/$pkgname/contrib"
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vicious-git.install b/vicious-git.install
deleted file mode 100644
index 30075f8c6aa1..000000000000
--- a/vicious-git.install
+++ /dev/null
@@ -1,23 +0,0 @@
-
-post_install() {
-cat << _EOF
-
-==> vicious installation notes:
- ----------------------------------------
- Vicious is a framework for gathering data about your system, and
- creating widgets to feed them that data in statusbars of various
- window managers, primarily the 'awesome' window manager. Vicious
- can be used with stable versions of awesome and development code,
- from the 3.4 branch or the master branch.
-
-_EOF
-
-}
-
-post_upgrade() {
- post_install
-}
-
-op=$1
-shift
-$op $*