summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-15 22:30:54 -0600
committerBrian Bidulock2015-07-15 22:30:54 -0600
commitffa9e6b3110eecd14b2cbae49c9549707693d92c (patch)
treecfdb19212cf4efc00f88a902879643171e5f3639
downloadaur-ffa9e6b3110eecd14b2cbae49c9549707693d92c.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD68
-rw-r--r--vicious-git.install23
3 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84da36f94746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vicious-git
+ pkgdesc = Modular widget library for window managers
+ pkgver = 2.1.3.9.g02e1142
+ pkgrel = 2
+ url = http://git.sysphere.org/vicious/about/
+ install = vicious-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = lua
+ optdepends = awesome: for which vicious was mainly written for
+ optdepends = hddtemp: for the HDD Temp widget type
+ optdepends = alsa-utils: for the Volume widget type
+ optdepends = wireless_tools: for the Wireless widget type
+ optdepends = curl: for widget types accessing network resources
+ provides = vicious
+ conflicts = vicious
+ source = vicious-git::git+http://git.sysphere.org/vicious
+ sha1sums = SKIP
+
+pkgname = vicious-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4a35d2589a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# -*- shell-script -*-
+#
+# Contributor: Adrian C. <anrxc..sysphere.org>
+
+pkgname=vicious-git
+_gitname=vicious
+pkgver=2.1.3.9.g02e1142
+_luaver="5.3"
+pkgrel=2
+pkgdesc="Modular widget library for window managers"
+arch=("any")
+url="http://git.sysphere.org/vicious/about/"
+license=("GPL2")
+depends=("lua")
+makedepends=("git")
+optdepends=("awesome: for which vicious was mainly written for"
+ "hddtemp: for the HDD Temp widget type"
+ "alsa-utils: for the Volume widget type"
+ "wireless_tools: for the Wireless widget type"
+ "curl: for widget types accessing network resources")
+provides=("vicious")
+conflicts=("vicious")
+install="${pkgname}.install"
+source=(${pkgname}::git+http://git.sysphere.org/${_gitname})
+sha1sums=("SKIP")
+
+
+pkgver() {
+ cd "${pkgname}"
+
+# git describe --always | sed 's|-|.|g'
+ git describe --always | sed 's|^[^0-9]*||;s|\.g[a-f0-9]*$||;s|-|.|g'
+}
+
+
+build() {
+ cd "${pkgname}"
+
+# Download or update the library
+# - automatic since pacman v4.1
+}
+
+
+package () {
+ cd "${pkgname}"
+
+# Install the vicious library
+ install -d "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}"
+ install -m644 *.lua "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}"
+
+# Install vicious widgets
+ install -d "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/widgets"
+ install -m644 widgets/*.lua "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/widgets"
+
+# Install user contributed widgets
+ install -d "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/contrib"
+ install -m644 contrib/*.lua "${pkgdir}/usr/share/lua/${_luaver}/${_gitname}/contrib"
+
+# Install support for legacy lua51
+ install -d "${pkgdir}/usr/share/lua/5.1"
+ ln -s /usr/share/lua/${_luaver}/vicious ${pkgdir}/usr/share/lua/5.1/vicious
+
+# Install the documentation
+ install -D -m644 CHANGES "${pkgdir}/usr/share/doc/${_gitname}/CHANGES"
+ install -m644 TODO "${pkgdir}/usr/share/doc/${_gitname}"
+ install -m644 README "${pkgdir}/usr/share/doc/${_gitname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/doc/${_gitname}"
+}
diff --git a/vicious-git.install b/vicious-git.install
new file mode 100644
index 000000000000..30075f8c6aa1
--- /dev/null
+++ b/vicious-git.install
@@ -0,0 +1,23 @@
+
+post_install() {
+cat << _EOF
+
+==> vicious installation notes:
+ ----------------------------------------
+ Vicious is a framework for gathering data about your system, and
+ creating widgets to feed them that data in statusbars of various
+ window managers, primarily the 'awesome' window manager. Vicious
+ can be used with stable versions of awesome and development code,
+ from the 3.4 branch or the master branch.
+
+_EOF
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+op=$1
+shift
+$op $*