summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Marques2015-06-12 11:30:42 +0100
committerFilipe Marques2015-06-12 11:30:42 +0100
commit84cdd4071e0474c4d04d420705dfa82cc2a96b15 (patch)
tree0342b3166c7f6f45edf8b585f1d8b48b6cf07e37
downloadaur-84cdd4071e0474c4d04d420705dfa82cc2a96b15.tar.gz
uploading to new aur
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61dc6f02a02b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Fri Apr 17 15:21:27 UTC 2015
+pkgbase = vicky
+ pkgdesc = GUI program that converts video files to sound files using ffmpeg
+ pkgver = 1.6.2
+ pkgrel = 2
+ url = https://github.com/filipe-marques/vicky
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-tools
+ depends = ffmpeg
+ depends = qt5-base
+ source = https://github.com/filipe-marques/vicky/archive/vicky-1.6.2.tar.gz
+ md5sums = 9bafae05a128c1fe3ace4fe8da9049d8
+
+pkgname = vicky
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6302a2c3c2fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Philip Müller <philm[at]manjaro[dot]org>
+# Developer: Filipe Marques <eagle[dot]software3[at]gmail[dot]com>
+
+pkgname=vicky
+pkgver=1.6.2
+pkgrel=2
+pkgdesc="GUI program that converts video files to sound files using ffmpeg"
+arch=('i686' 'x86_64')
+url="https://github.com/filipe-marques/vicky"
+license=('GPL')
+depends=('ffmpeg' 'qt5-base')
+makedepends=('qt5-tools')
+source=("$url/archive/$pkgname-$pkgver.tar.gz")
+md5sums=('9bafae05a128c1fe3ace4fe8da9049d8')
+
+build() {
+ cd $srcdir/vicky-$pkgname-$pkgver
+ qmake-qt5 vicky.pro
+ make
+}
+
+package() {
+ cd $srcdir/vicky-$pkgname-$pkgver
+ #make install INSTALL_ROOT=$pkgdir
+
+ install -Dm755 "Vicky" "${pkgdir}/usr/bin/vicky"
+ install -Dm644 "vicky.desktop" "${pkgdir}/usr/share/applications/vicky.desktop"
+ install -Dm644 "resource/icons/vicky24.png" "${pkgdir}/usr/share/icons/vicky.png"
+ install -Dm644 "resource/icons/vicky24.png" "${pkgdir}/usr/share/icons/hicolor/24x24/apps/vicky.png"
+ install -Dm644 "resource/icons/vicky128.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/vicky.png"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/vicky/LICENSE"
+}