summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-02-27 15:37:48 +0200
committerDimitris Kiziridis2020-02-27 15:37:48 +0200
commit229273e7ce49e165c8cc7bf6cd018473a53d547c (patch)
tree19a02bf98133cce9eca84c3f44d34e1af4f0850c
parenta8ce414f5bc246af1eabd247cba194f7b1caebb5 (diff)
downloadaur-229273e7ce49e165c8cc7bf6cd018473a53d547c.tar.gz
Upstream changed to Gitlab
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e21e26cd8a05..7cca103d50f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = victory-icon-theme-git
- pkgdesc = A GTK icon theme for Linux by newhoa
- pkgver = 1.16.557592d
+ pkgdesc = Victory Icon Theme, A GTK Icon Theme for Linux
+ pkgver = 1.1.a8ce414
pkgrel = 1
- url = https://github.com/newhoa/victory-icon-theme
+ url = https://gitlab.com/newhoa/victory-icon-theme
arch = any
license = GPL3
makedepends = git
- provides = victory-icon-theme-git
- conflicts = victory-icon-theme-git
- source = victory-icon-theme-git::git+https://github.com/newhoa/victory-icon-theme.git
+ provides = victory-icon-theme
+ conflicts = victory-icon-theme
+ source = git+https://gitlab.com/newhoa/victory-icon-theme.git
md5sums = SKIP
pkgname = victory-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 281aff08c51c..fe7552f87485 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
# Maintainer: Simon Paul <simonpaul at mailbox dot org>
pkgname=victory-icon-theme-git
-pkgver=1.16.557592d
+pkgver=1.1.a8ce414
pkgrel=1
-pkgdesc='A GTK icon theme for Linux by newhoa'
+pkgdesc='Victory Icon Theme, A GTK Icon Theme for Linux'
arch=('any')
-url='https://github.com/newhoa/victory-icon-theme'
+url='https://gitlab.com/newhoa/victory-icon-theme'
license=('GPL3')
-depends=()
makedepends=('git')
-provides=('victory-icon-theme-git')
-conflicts=('victory-icon-theme-git')
-source=('victory-icon-theme-git::git+https://github.com/newhoa/victory-icon-theme.git')
+provides=('victory-icon-theme')
+conflicts=('victory-icon-theme')
+source=("git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd victory-icon-theme-git
+ cd "${srcdir}/victory-icon-theme"
printf "1.%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/victory-icon-theme"
+ rm Changelog Credits GPL3 LICENSE README.md
+ rm -rf Alts
+ rm -rf .git
+}
+
package() {
- cd victory-icon-theme-git
+ cd "${srcdir}/victory-icon-theme"
install -dm 755 "${pkgdir}"/usr/share/icons/Victory-Icon-Theme
rm -rf .git .gitignore
cp -dr --no-preserve='ownership' * "${pkgdir}"/usr/share/icons/Victory-Icon-Theme/
}
-
-# vim: ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: \ No newline at end of file