summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPete Alexandrou2018-08-02 20:06:34 +1000
committerPete Alexandrou2018-08-02 20:06:34 +1000
commit6617d6db3d44c84772e9bcd0d687048a856a6e2f (patch)
tree6869ec6e70dfe595cb36d73be2127065748773fc
parent1ed52607559badf78fc1c25e5e789d95fed3dca5 (diff)
downloadaur-6617d6db3d44c84772e9bcd0d687048a856a6e2f.tar.gz
6.0.0 release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD8
-rw-r--r--changelog66
3 files changed, 79 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c528ebdf0b49..9a31ca6dd950 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = vidcutter
pkgdesc = A modern, simple to use, constantly evolving and hella fast MEDIA CUTTER + JOINER w/ frame-accurate SmartCut technology + Qt5, libmpv, FFmpeg and MediaInfo powering the backend.
- pkgver = 5.5.0
- pkgrel = 2
+ pkgver = 6.0.0
+ pkgrel = 1
url = https://vidcutter.ozmartians.com
install = vidcutter.install
changelog = changelog
arch = x86_64
license = GPL3
makedepends = python-setuptools
- depends = python-pyqt5
- depends = mpv
depends = ffmpeg
depends = mediainfo
+ depends = mpv
+ depends = python-opengl
+ depends = python-pyqt5
+ depends = python-setuptools
+ depends = python-simplejson
provides = vidcutter
conflicts = vidcutter-git
- source = https://github.com/ozmartian/vidcutter/archive/5.5.0.tar.gz
- sha256sums = 0ea962a6bbad45983a37d1961aca866382228e018043c728d35365599acc0cd5
+ source = https://github.com/ozmartian/vidcutter/archive/6.0.0.tar.gz
+ sha256sums = 67a420f8698b92a230257c50bcd0eecd562b6577c0dba738fc5e4b4ef7b8f87e
pkgname = vidcutter
diff --git a/PKGBUILD b/PKGBUILD
index 11a4a85ce193..f2cb4b3af48e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Pete Alexandrou <pete@ozmartians.com>
pkgname=vidcutter
-pkgver=5.5.0
-pkgrel=2
+pkgver=6.0.0
+pkgrel=1
pkgdesc='A modern, simple to use, constantly evolving and hella fast MEDIA CUTTER + JOINER w/ frame-accurate SmartCut technology + Qt5, libmpv, FFmpeg and MediaInfo powering the backend.'
arch=('x86_64')
license=('GPL3')
url="https://vidcutter.ozmartians.com"
source=(https://github.com/ozmartian/${pkgname}/archive/${pkgver}.tar.gz)
changelog=changelog
-depends=('python-pyqt5' 'mpv' 'ffmpeg' 'mediainfo')
+depends=('ffmpeg' 'mediainfo' 'mpv' 'python-opengl' 'python-pyqt5' 'python-setuptools' 'python-simplejson')
makedepends=('python-setuptools')
install=${pkgname}.install
provides=('vidcutter')
conflicts=('vidcutter-git')
-sha256sums=('0ea962a6bbad45983a37d1961aca866382228e018043c728d35365599acc0cd5')
+sha256sums=('67a420f8698b92a230257c50bcd0eecd562b6577c0dba738fc5e4b4ef7b8f87e')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/changelog b/changelog
index 8e40b99b09bc..a99cad2e28eb 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,69 @@
+vidcutter (6.0.0-1) stable; urgency=medium
+
+ * MAJOR FEATURE: video filters menu option added to app menu accessed via
+ right-click or the bottom-right menu button. the first filter available
+ is BLACKDETECT which automatically creates clips in your clip index based
+ around black scene changes that are detected. selecting the filter once
+ a media file has been loaded will prompt for a black scene minimum
+ duration in seconds, allowing you to tweak the black frame sensitivity to
+ reduce or increase the amount of scenes detected. this is mainly useful for
+ skipping commercials (e.g. comskip) or auto-detecting scene transitions.
+ more filters will be added in future updates.
+
+ * MAJOR FEATURE: automatic chapters created per clip in your list. enabled by
+ default and can be toggled via Settings -> General and a new toggle button
+ in the left hand side group of the UI buttons.
+
+ * MAJOR FEATURE: chapter names can be edited from their default set values
+ via new edit chapter option when right-clicking on a clip in your list. all
+ clip will default to "Chapter <x>" as their default text which is what
+ a media center or half-decent player will display in menu and you are
+ able to skip directly to each clip point using standard previous/next buttons
+ (if they are set in their default state, obviously)
+
+ * External media file joins (when wanting to just join a set of files using the
+ the ADD button under the Video Index) are fixed; the last version broke
+ this once timeline progressbars were added. Progress for external joins
+ is displayed in progressbars overlaying associated clips directly in the
+ Clip Index which replaces timeline progressbar functionality when all clips
+ are external (i.e. not loaded via Open Media thus not associated with a
+ project)
+
+ * Added new "Enable use of PBOs" setting under the Video category for use of
+ pixel buffer objects when rendering OpenGL video. Used for noticeable
+ performance improvements when working with huge/4K media files.
+
+ * Fixed a bug caused when removing a clip with a start time but no end time
+ from your index.
+
+ * OSD (on-screen display) text defined for all user actions + standardised
+ OSD case and wording/format.
+
+ * Main clip list's scrolling mode changed to per pixel for smoother
+ vertical scrolling and no snapping of clips as they are scrolled into
+ view.
+
+ * snap + Flatpak manifests completed w/ app now available from respective
+ stores and repos (i.e snapcraft.io + flathub.org). These builds come
+ prepacked with the very latest releases of FFmpeg, libmpv, MediaInfo as
+ well as the UI libraries for Qt5 and PyQt5.
+
+ * Fixed clip index heading not extending to full width of list when it
+ becomes scrollable when more than 4 clips are added to the index.
+
+ * LINUX: all icons, desktop, mime-type, appstream related files has have
+ been renamed to domain based app-id (com.ozmartians.VidCutter) as per
+ freedesktop specs. updates made to support this across the vast array of
+ deploy/build scripts. makes things much more tidy and less error prone in
+ AppImage, Flatpak and Snap package build scripts.
+
+ * UI improvements to media stream dialog; most consistent across differing
+ desktop sizes and stream configurations
+
+ * Flatpak: Qt 5.11 + dependency updates + NVIDIA h/w decoding fixes
+
+ -- Pete Alexandrou <pete@ozmartians.com> Thu, 02 Aug 2018 18:20:00 +1000
+
vidcutter (5.5.0-1) stable; urgency=medium
* The most requested feature is finally added; media stream configuration! A