summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPete Alexandrou2017-11-16 00:29:23 +0800
committerPete Alexandrou2017-11-16 00:29:23 +0800
commit9eb56ea1843d032d96c5a501375b09bb22858275 (patch)
tree51d71c90f07fee8c3d0b04a801c7494d2c512e01
parent86981d3da32f77a9c9eece5551fe5746dc758138 (diff)
downloadaur-9eb56ea1843d032d96c5a501375b09bb22858275.tar.gz
5.0.0 release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--changelog50
3 files changed, 63 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c17e2b2fccb0..7dd01a68409c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = vidcutter
- pkgdesc = the simplest + fastest video cutter & joiner
- pkgver = 4.0.0
- pkgrel = 2
- url = http://vidcutter.ozmartians.com
+ pkgdesc = the simplest + fastest video cutter and joiner
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://vidcutter.ozmartians.com
install = vidcutter.install
changelog = changelog
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL3
makedepends = python-setuptools
depends = python-pyqt5
@@ -15,8 +16,8 @@ pkgbase = vidcutter
depends = python-opengl
provides = vidcutter
conflicts = vidcutter-git
- source = https://github.com/ozmartian/vidcutter/archive/4.0.0.tar.gz
- sha256sums = 18686af2454480f6aa2ba2c27cd32f8a1b580309460c6b3ee9fb03ccfeecf513
+ source = https://github.com/ozmartian/vidcutter/archive/5.0.0.tar.gz
+ sha256sums = 651177b002284752225b67c8368835723ab569f253df76ea4cb1add61cbd3e8a
pkgname = vidcutter
diff --git a/PKGBUILD b/PKGBUILD
index 2fa402c4e3c8..c9137b2a08a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Pete Alexandrou <pete@ozmartians.com>
pkgname=vidcutter
-pkgver=4.0.0
-pkgrel=2
-pkgdesc="the simplest + fastest video cutter & joiner"
-arch=('any')
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="the simplest + fastest video cutter and joiner"
+arch=('i686' 'x86_64')
license=('GPL3')
-url="http://vidcutter.ozmartians.com"
+url="https://vidcutter.ozmartians.com"
source=(https://github.com/ozmartian/${pkgname}/archive/${pkgver}.tar.gz)
changelog=changelog
depends=('python-pyqt5' 'mpv' 'ffmpeg' 'mediainfo' 'python-opengl')
@@ -13,12 +13,7 @@ makedepends=('python-setuptools')
install=${pkgname}.install
provides=('vidcutter')
conflicts=('vidcutter-git')
-sha256sums=('18686af2454480f6aa2ba2c27cd32f8a1b580309460c6b3ee9fb03ccfeecf513')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i "s/pypi/arch/" "${pkgname}/__init__.py"
-}
+sha256sums=('651177b002284752225b67c8368835723ab569f253df76ea4cb1add61cbd3e8a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/changelog b/changelog
index 01931b47e930..501308c28508 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,51 @@
+vidcutter (5.0.0-1) stable; urgency=medium
+
+ * SmartCut feature introduced for frame accurate cuts; beginning and end
+ clip segments are reencoded and joined with middle segment for each clip
+ defined in the Clip Index along source video's defined keyframes
+
+ * SmartCut enabled via app settings as well as toggle button on the main
+ interface. SmartCut can take up to 2 mins vs a few seconds so use it
+ only if frame accuracy is a requirement
+
+ * new progress bars on clips in timeline to visualise video processing in
+ more accurate and modern way
+
+ * thumbnail generation accuracy fixed so thumbnails generated accurately
+ match frame with timecode placement
+
+ * new "View keyframes" button option available under Video Info which
+ displays the source video's defined keyframes which are utilised
+ by the new SmartCut feature
+
+ * improvements made to standard quick cutting to make them as frame
+ accurate as can be given the source's media codec and container
+
+ * improvements to stream mapping to help ensure all source media's
+ streams (video, audio, text/subtitles) are included in the target
+ video produced. only if problems are found during the cut/join
+ process will this be abandoned and FFmpeg then allowed to make its
+ usual "best choice" in choosing the best streams for you
+
+ * single app instance code added along with a settings option to force all
+ file manager associated tasks to the single already loaded instance of
+ VidCutter
+
+ * .vcp registered as "VidCutter Project file" for Linux and Windows
+ installations
+
+ * more debugging information available for the console or "--debug"
+ command-line argument
+
+ * new verbose logging option added to settings for even more verbose
+ logging in the application log file, console window and debug command-
+ line output if running with the "--debug" argument (Linux only)
+
+ * new app icon; hopefully this one sticks :-)
+
+ * countless more improvements and fixes that aren't worth documenting but
+ available in the freely available commit logs if you're interested
+
vidcutter (4.0.0-1) stable; urgency=medium
* pure OpenGL rendered window output
@@ -262,4 +310,4 @@ vidcutter (2.0.0-1) unstable; urgency=low
* source package automatically created by stdeb 0.8.5
-- Pete Alexandrou <pete@ozmartians.com> Mon, 02 Jan 2017 08:41:42 +0800
- \ No newline at end of file
+