summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPete Alexandrou2016-12-29 23:06:24 +0800
committerPete Alexandrou2016-12-29 23:06:24 +0800
commit81a4fcc7cf1474a2b7cafb72df3c50a9e26b4d93 (patch)
tree15ceb6370faa987d71d878b2e3a9de027b8ee960
downloadaur-81a4fcc7cf1474a2b7cafb72df3c50a9e26b4d93.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a9ea0b82eaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vidcutter-git
+ pkgdesc = FFmpeg based video cutter & joiner with a modern PyQt5 GUI
+ pkgver = 2.0.0.r0.gde179c3
+ pkgrel = 1
+ url = http://vidcutter.ozmartians.com
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-pyqt5
+ depends = qt5-multimedia
+ depends = ffmpeg
+ depends = python-qtawesome-git
+ conflicts = vidcutter
+ source = vidcutter-git::git+https://github.com/ozmartian/vidcutter.git
+ md5sums = SKIP
+
+pkgname = vidcutter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43fd6ac1e593
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Pete Alexandrou (ozmartian) <pete@ozmartians.com>
+pkgname=vidcutter-git
+pkgver=2.0.0.r0.gde179c3
+pkgrel=1
+pkgdesc="FFmpeg based video cutter & joiner with a modern PyQt5 GUI"
+arch=('any')
+license=('GPL3')
+url="http://vidcutter.ozmartians.com"
+source=('vidcutter-git::git+https://github.com/ozmartian/vidcutter.git')
+depends=('python-pyqt5' 'qt5-multimedia' 'ffmpeg' 'python-qtawesome-git')
+makedepends=('git' 'python-setuptools')
+provides=()
+conflicts=('vidcutter')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "_build/vidcutter.desktop" "${pkgdir}/usr/share/applications/vidcutter.desktop"
+ install -Dm644 "images/vidcutter.png" "${pkgdir}/usr/share/pixmaps/vidcutter.png"
+}