summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPete Alexandrou2020-12-04 01:15:08 +1100
committerPete Alexandrou2020-12-04 01:15:08 +1100
commitf7b5774fda451d40509b0886cf566a6d040bc576 (patch)
treea65b5f9ea675937fb9a6f260d24cb12795789cf5
parentebb08099fb7d918447ec947d420f0d983f9e3054 (diff)
downloadaur-f7b5774fda451d40509b0886cf566a6d040bc576.tar.gz
switch to HEAD instead of fixed release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05a7b6818d7d..98b2daaea80c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vidcutter-git
pkgdesc = A modern, simple to use, constantly evolving and hella fast MEDIA CUTTER + JOINER w/ frame-accurate SmartCut technology + Qt5, libmpv, FFmpeg and MediaInfo powering the backend.
pkgver = 6.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://vidcutter.ozmartians.com
install = vidcutter-git.install
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = vidcutter-git
depends = python-simplejson
provides = vidcutter
conflicts = vidcutter
- source = https://github.com/ozmartian/vidcutter/archive/6.0.5.tar.gz
+ source = git+https://github.com/ozmartian/vidcutter.git
sha256sums = SKIP
pkgname = vidcutter-git
diff --git a/PKGBUILD b/PKGBUILD
index 63aa537ffa93..8ce84ea6e087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Pete Alexandrou <pete@ozmartians.com>
pkgname=vidcutter-git
pkgver=6.0.5
-pkgrel=1
+pkgrel=2
pkgdesc='A modern, simple to use, constantly evolving and hella fast MEDIA CUTTER + JOINER w/ frame-accurate SmartCut technology + Qt5, libmpv, FFmpeg and MediaInfo powering the backend.'
arch=('x86_64')
license=('GPL3')
url="https://vidcutter.ozmartians.com"
-source=(https://github.com/ozmartian/${pkgname%-git}/archive/${pkgver}.tar.gz)
+# source=(https://github.com/ozmartian/${pkgname%-git}/archive/${pkgver}.tar.gz)
+source=(git+https://github.com/ozmartian/vidcutter.git)
depends=('ffmpeg' 'mediainfo' 'mpv' 'python-opengl' 'python-pyqt5' 'python-setuptools' 'python-simplejson')
makedepends=('python-setuptools')
install=${pkgname}.install
@@ -20,11 +21,11 @@ sha256sums=('SKIP')
# }
build() {
- cd "${srcdir}/${pkgname%-git}-${pkgver}"
+ cd "${srcdir}/${pkgname%-git}"
python3 setup.py build
}
package() {
- cd "${srcdir}/${pkgname%-git}-${pkgver}"
- python3 setup.py install --root="${pkgdir}" --optimize=2 --skip-build
+ cd "${srcdir}/${pkgname%-git}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}