summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Baboni Dominiquini2024-09-01 12:32:33 -0300
committerRafael Baboni Dominiquini2024-09-01 12:32:33 -0300
commit69da93f06950c098017593098d4e16836b4dfadc (patch)
tree4156566aa49c2fa199a881261db3e5d1dddc698c
parentf4db54a1525053dce3787fe9a03f05e2d06d2914 (diff)
downloadaur-69da93f06950c098017593098d4e16836b4dfadc.tar.gz
Update to version 'v1.0.2'
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD8
-rw-r--r--README.md166
4 files changed, 199 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2f412daf31f..7e29283e7410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = viddy-bin
pkgdesc = A modern watch command, binary version
- pkgver = 0.4.0
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/sachaos/viddy
arch = x86_64
@@ -8,7 +8,11 @@ pkgbase = viddy-bin
depends = glibc
provides = viddy
conflicts = viddy
- source = https://github.com/sachaos/viddy/releases/download/v0.4.0/viddy_Linux_x86_64.tar.gz
- sha256sums = c6bd8b9889faa8680ea97c7392efe31788a9700cc5a84a26f9ecd317c932b9ac
+ source = https://github.com/sachaos/viddy/releases/download/v1.0.2/viddy-v1.0.2-linux-x86_64.tar.gz
+ source = LICENSE
+ source = README.md
+ sha256sums = d0c22d069349ce9ffc9fcda3c5f5e06312ea6813a986b2b860934830fd1f5f06
+ sha256sums = e6eea22d4e9e0aa6a78d0f9126009ec041ea047f94b320c003c34a631821f953
+ sha256sums = a298e1ff099a75d44883a68f2f01e5895b82ce83ff55e22439be768858eeb49b
pkgname = viddy-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e39cc9a6d563
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2021 Takumasa Sakao @sachaos
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 0b590b2e616a..06e2f9ca4c64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: solnce <echo c29sbmNlQHJhdGFqY3phay5vbmU= | base64 -d>
_pkgname=viddy
pkgname=${_pkgname}-bin
-pkgver=0.4.0
+pkgver=1.0.2
pkgrel=1
pkgdesc='A modern watch command, binary version'
url="https://github.com/sachaos/viddy"
-source=("${url}/releases/download/v$pkgver/${_pkgname}_Linux_x86_64.tar.gz")
+source=("${url}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux-x86_64.tar.gz" "LICENSE" "README.md")
arch=('x86_64')
license=('MIT')
depends=('glibc')
conflicts=('viddy')
provides=('viddy')
-sha256sums=('c6bd8b9889faa8680ea97c7392efe31788a9700cc5a84a26f9ecd317c932b9ac')
+sha256sums=('d0c22d069349ce9ffc9fcda3c5f5e06312ea6813a986b2b860934830fd1f5f06'
+ 'e6eea22d4e9e0aa6a78d0f9126009ec041ea047f94b320c003c34a631821f953'
+ 'a298e1ff099a75d44883a68f2f01e5895b82ce83ff55e22439be768858eeb49b')
package() {
cd "$srcdir/"
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..af9b0eb4caa0
--- /dev/null
+++ b/README.md
@@ -0,0 +1,166 @@
+# Viddy
+
+<p align="center">
+<img src="images/logo.png" width="200" alt="viddy" title="viddy" />
+</p>
+
+Modern `watch` command.
+
+Viddy well, gopher. Viddy well.
+
+## Demo
+
+<p align="center">
+<img src="images/demo.gif" width="100%" alt="viddy" title="viddy" />
+</p>
+
+## Features
+
+* Basic features of original watch command.
+ * Execute command periodically, and display the result.
+ * color output.
+ * diff highlight.
+* Time machine mode. 😎
+ * Rewind like video.
+ * Go to the past, and back to the future.
+* Look back history.
+ * Save and load history.
+* See output in pager.
+* Vim like keymaps.
+* Search text.
+* Suspend and restart execution.
+* Support shell alias
+ * See detail https://github.com/sachaos/viddy/issues/2#issuecomment-904002053
+* Customize keymappings.
+* Customize color.
+
+## Install
+
+### Cargo
+
+```shell
+cargo install viddy
+```
+
+### [Homebrew](https://brew.sh)
+
+```shell
+brew install viddy
+```
+
+### Linux
+
+```shell
+wget -O viddy.tar.gz https://github.com/sachaos/viddy/releases/download/v1.0.2/viddy-v1.0.2-linux-x86_64.tar.gz && tar xvf viddy.tar.gz && mv viddy /usr/local/bin
+```
+
+### Other
+
+Download from [release page](https://github.com/sachaos/viddy/releases).
+
+## Install with Other Package Managers (Community-Maintained)
+
+#### [MacPorts](https://www.macports.org)
+
+```shell
+sudo port install viddy
+```
+
+#### [Scoop](https://scoop.sh/)
+
+To install Viddy on Windows, first install the Scoop package manager, and then run the commands below.
+
+**NOTE**: The git package is required in order to add additional Scoop "buckets".
+
+```
+scoop install git
+scoop bucket add extras
+scoop install extras/viddy
+```
+
+#### ArchLinux ( AUR )
+
+```shell
+yay -S viddy
+```
+Alternatively you can use the [AUR Git repo](https://aur.archlinux.org/packages/viddy/) directly
+
+#### Alpine Linux
+
+After [enabling the community repository](https://wiki.alpinelinux.org/wiki/Enable_Community_Repository):
+
+```shell
+apk add viddy
+```
+
+#### [asdf version manager](https://asdf-vm.com)
+
+```shell
+asdf plugin add viddy
+asdf install viddy latest
+asdf global viddy latest
+```
+
+## Keymaps
+
+| key | |
+|-----------|--------------------------------------------|
+| SPACE | Toggle time machine mode |
+| s | Toggle <ins>s</ins>uspend execution |
+| b | Toggle ring terminal <ins>b</ins>ell |
+| d | Toggle <ins>d</ins>iff |
+| t | Toggle header/<ins>t</ins>itle display |
+| ? | Toggle help view |
+| / | Search text |
+| j | Pager: next line |
+| k | Pager: previous line |
+| h | Pager: move left |
+| l | Pager: move right |
+| Control-F | Pager: page down |
+| Control-B | Pager: page up |
+| g | Pager: go to top of page |
+| Shift-G | Pager: go to bottom of page |
+| Shift-J | (Time machine mode) Go to the past |
+| Shift-K | (Time machine mode) Back to the future |
+| Shift-F | (Time machine mode) Go to more past |
+| Shift-B | (Time machine mode) Back to more future |
+| Shift-O | (Time machine mode) Go to oldest position |
+| Shift-N | (Time machine mode) Go to current position |
+
+## Configuration
+
+Viddy can be used without any configuration.
+However, if you want to customize the keybindings or default behavior, you can do so.
+
+Install your config file on `$XDG_CONFIG_HOME/viddy.toml`
+On macOS, the path is `~/Library/Application\ Support/viddy.toml`.
+
+```toml
+[general]
+no_shell = false
+shell = "zsh"
+shell_options = ""
+skip_empty_diffs = false
+
+[keymap]
+timemachine_go_to_past = "Down"
+timemachine_go_to_more_past = "Shift-Down"
+timemachine_go_to_future = "Up"
+timemachine_go_to_more_future = "Shift-Up"
+timemachine_go_to_now = "Ctrl-Shift-Up"
+timemachine_go_to_oldest = "Ctrl-Shift-Down"
+
+[color]
+background = "white" # Default value is inherit from terminal color.
+```
+
+## What is "viddy" ?
+
+"viddy" is Nadsat word meaning to see.
+Nadsat is fictional argot of gangs in the violent book and movie "A Clockwork Orange".
+
+## Credits
+
+The gopher's logo of viddy is licensed under the Creative Commons 3.0 Attributions license.
+
+The original Go gopher was designed by [Renee French](https://reneefrench.blogspot.com/).