summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-04-11 20:45:56 +0200
committerMarcell Meszaros2022-04-11 20:45:56 +0200
commit9413bd7127d8c77816f0da4eaf6a02b8140cd0de (patch)
tree606ef4190baf37674b80416f603fc89b9c6444ff
parent4de9e415a221f67fab72dd607a6ed52d7c0086b1 (diff)
downloadaur-9413bd7127d8c77816f0da4eaf6a02b8140cd0de.tar.gz
updpkg 0.9.6
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74d3be41927e..df38a50dc597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = video-downloader
pkgdesc = GTK application to download videos from websites like YouTube and many others (based on yt-dlp)
- pkgver = 0.9.4
+ pkgver = 0.9.6
pkgrel = 1
url = https://github.com/Unrud/video-downloader
arch = any
@@ -16,7 +16,7 @@ pkgbase = video-downloader
depends = python-pyxattr
depends = python-websockets
depends = yt-dlp
- source = git+https://github.com/Unrud/video-downloader.git/#commit=da1c4d2b2a0965345b25d33af896010e57dd4229
+ source = git+https://github.com/Unrud/video-downloader.git#tag=v0.9.6
b2sums = SKIP
pkgname = video-downloader
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index c1506e067d8b..ba35d95d5e66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,18 @@
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Kevin Majewski < kevin.majewski02 AT gmail.com >
+
pkgname=video-downloader
-pkgver=0.9.4
+pkgver=0.9.6
pkgrel=1
-pkgdesc="GTK application to download videos from websites like YouTube and many others (based on yt-dlp)"
-arch=(any)
+pkgdesc='GTK application to download videos from websites like YouTube and many others (based on yt-dlp)'
+arch=('any')
url="https://github.com/Unrud/${pkgname}"
license=('GPL3')
depends=('ffmpeg' 'gtk3' 'libhandy' 'python-gobject' 'python-mutagen' 'python-pycryptodomex' 'python-pyxattr' 'python-websockets' 'yt-dlp')
makedepends=('git' 'meson')
-_commit=da1c4d2b2a0965345b25d33af896010e57dd4229 # tags/0.9.4
-source=("git+https://github.com/Unrud/${pkgname}.git/#commit=$_commit")
+source=("git+${url}.git#tag=v${pkgver}")
b2sums=('SKIP')
-pkgver() {
- cd ${pkgname}
- git describe --tags | sed 's/-/+/g'
-}
-
build() {
arch-meson ${pkgname} build
meson compile -C build