summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-06-07 00:29:57 +0000
committerBalló György2020-06-07 00:29:57 +0000
commitbdfa0bf2f49e12244e4c17511dd9edae19f28f32 (patch)
tree7db15dc4187c9738cf654a84841fe8a512dd8efd
downloadaur-bdfa0bf2f49e12244e4c17511dd9edae19f28f32.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..725f9a2d7e90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = video-downloader
+ pkgdesc = GTK application to download videos from websites like YouTube and many others (based on youtube-dl)
+ pkgver = 0.2.9
+ pkgrel = 1
+ url = https://github.com/Unrud/video-downloader
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = python-gobject
+ depends = youtube-dl
+ source = git+https://github.com/Unrud/video-downloader#commit=322f54dbd5b9c9acaa43cff40471d876b2a22dcf
+ sha256sums = SKIP
+
+pkgname = video-downloader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9f45ae80987
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=video-downloader
+pkgver=0.2.9
+pkgrel=1
+pkgdesc="GTK application to download videos from websites like YouTube and many others (based on youtube-dl)"
+arch=(any)
+url="https://github.com/Unrud/video-downloader"
+license=('GPL3')
+depends=(gtk3 python-gobject youtube-dl)
+makedepends=(git meson)
+_commit=322f54dbd5b9c9acaa43cff40471d876b2a22dcf # tags/0.2.9
+source=("git+https://github.com/Unrud/video-downloader#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}