summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2015-12-27 23:24:36 +0100
committerMartchus2015-12-27 23:24:36 +0100
commitde25aa725fd2a9ccd2aed645c8e69411f97e5767 (patch)
tree0df9ea1a9810d2a40fc44613290e893d9de138d4
parent79d9fe4eb280b6206158e75204418b80bca663bf (diff)
downloadaur-de25aa725fd2a9ccd2aed645c8e69411f97e5767.tar.gz
updated version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
-rw-r--r--videodownloader.install8
3 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fe741a41078..d403f882f624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 22:05:28 UTC 2015
pkgbase = videodownloader
- pkgdesc = A video downloader with Qt GUI (currently only YouTube is maintained).
- pkgver = 1.2.1
+ pkgdesc = A video downloader with Qt GUI (currently only YouTube and Vimeo are maintained).
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/Martchus/videodownloader
install = videodownloader.install
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
makedepends = qt5-tools
depends = qtutilities
depends = openssl
depends = desktop-file-utils
depends = xdg-utils
- source = videodownloader-1.2.1.tar.gz::https://github.com/Martchus/videodownloader/archive/v1.2.1.tar.gz
- sha256sums = fefa04939c9310474e70b509142f7d7330e1c175d3507a081c58f447a34da347
+ source = videodownloader-1.3.0.tar.gz::https://github.com/Martchus/videodownloader/archive/v1.3.0.tar.gz
+ sha256sums = 0680db3887715f6147247d2344745794fac6d6d57daf0173c8e2ac29b5392e30
pkgname = videodownloader
diff --git a/PKGBUILD b/PKGBUILD
index 1d5c22080f7d..98cbb06ab389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Martchus <martchus@gmx.net>
_reponame=videodownloader
pkgname=videodownloader
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
arch=('i686' 'x86_64')
-pkgdesc="A video downloader with Qt GUI (currently only YouTube is maintained)."
+pkgdesc="A video downloader with Qt GUI (currently only YouTube and Vimeo are maintained)."
license=('GPL')
depends=('qtutilities' 'openssl' 'desktop-file-utils' 'xdg-utils')
-makedepends=('qt5-tools')
+makedepends=('cmake' 'qt5-tools')
install=${pkgname}.install
url="https://github.com/Martchus/${_reponame}"
source=("videodownloader-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('fefa04939c9310474e70b509142f7d7330e1c175d3507a081c58f447a34da347')
+sha256sums=('0680db3887715f6147247d2344745794fac6d6d57daf0173c8e2ac29b5392e30')
build() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- INSTALL_ROOT=$pkgdir/usr/ qmake-qt5 "$pkgname.pro"
- make
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ make
}
package() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- make install
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make install
}
diff --git a/videodownloader.install b/videodownloader.install
index 5495fb1b5d27..5c501dc49916 100644
--- a/videodownloader.install
+++ b/videodownloader.install
@@ -1,12 +1,12 @@
post_install() {
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
}
post_upgrade() {
- post_install
+ post_install
}
post_remove() {
- post_install
+ post_install
}