summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:40:40 -0400
committerFrançois Boulogne2015-06-09 21:40:40 -0400
commiteb6f5db808e64f55e04cda7a7b6d48d123c404cb (patch)
tree577d99fb6148cee8b40147d28b137eb030ff0275
downloadaur-eb6f5db808e64f55e04cda7a7b6d48d123c404cb.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fed75377ae6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = videomaker
+ pkgdesc = Build a movie from pictures
+ pkgver = 0.2
+ pkgrel = 2
+ url = https://github.com/sciunto/VideoMaker
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = texlive-core
+ depends = texlive-bin
+ depends = mencoder
+ depends = ffmpeg
+ depends = python-pillow
+ source = https://source.sciunto.org/videomaker/VideoMaker-0.2.tar.bz2
+ md5sums = 1d02ea2a6cc7ca4381df15322ee61843
+
+pkgname = videomaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffba1a0ebf6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+
+pkgname=videomaker
+pkgver=0.2
+pkgrel=2
+pkgdesc="Build a movie from pictures"
+arch=('any')
+url="https://github.com/sciunto/VideoMaker"
+license=('GPL3')
+depends=('python' 'texlive-core' 'texlive-bin' 'mencoder' 'ffmpeg' 'python-pillow')
+makedepends=('python-setuptools')
+source=(https://source.sciunto.org/videomaker/VideoMaker-${pkgver}.tar.bz2)
+md5sums=("1d02ea2a6cc7ca4381df15322ee61843")
+
+build() {
+ cd "${srcdir}/"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/"
+ python setup.py install --root="${pkgdir}"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+
+# vim:ts=2:sw=2:et: