summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2024-02-14 00:12:42 +0100
committerPopolon2024-02-14 00:12:42 +0100
commitbb521dc1827ad8846f9ba64da2e65095673424b6 (patch)
tree468ff1fe0c531c82dc5b95cf3d73a4357a666c5f
parent049db68dbdb040a781df63e7c0749bd590770c2f (diff)
downloadaur-bb521dc1827ad8846f9ba64da2e65095673424b6.tar.gz
fusionned pkgbase/pkgname/_module fusioned in pkgbase
change gpl-3 to gpl-3.0-only add python-wheel in makedepends
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c9649d6efa6..32e3b3a1bcdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = videomass
pkgdesc = A cross-platform GUI for FFmpeg and youtube-dl or yt-dlp
pkgver = 5.0.4
- pkgrel = 1
+ pkgrel = 2
url = http://jeanslack.github.io/Videomass/
arch = any
- license = GPL
+ license = GPL-3.0-only
makedepends = python-build
makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-wxpython
depends = python-pypubsub
diff --git a/PKGBUILD b/PKGBUILD
index ed106a98f124..b6fc176f8fe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,6 @@
-pkgbase='videomass'
-pkgname=('videomass')
-_module='videomass'
+pkgname='videomass'
pkgver='5.0.4'
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform GUI for FFmpeg and youtube-dl or yt-dlp"
url="http://jeanslack.github.io/Videomass/"
depends=('python' 'python-wxpython' 'python-pypubsub' 'python-requests' 'ffmpeg')
@@ -10,19 +8,19 @@ optdepends=(
'atomicparsley: For parsing MP4 metadata'
'yt-dlp: Modernified version of youtube-dl, for extracting videos'
)
-makedepends=('python-build' 'python-installer')
-license=('GPL')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+license=('GPL-3.0-only')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('26dbf5b8bfd7c82f2038aed5c83b001c9685bd7821f3030ea759465808e8f2c8')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python -m build --wheel --no-isolation
}
package() {
depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python -m installer --destdir="${pkgdir}" dist/*.whl
}