summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:38:57 +0200
committerM0Rf302015-06-17 16:38:57 +0200
commite727fda3d1194ae58b32f394af410f35a1ef885e (patch)
tree3d83b4117dc8f8ccee77b2eea89aa2c94219e19e
downloadaur-e727fda3d1194ae58b32f394af410f35a1ef885e.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--videosnarf-0.63-fix-linking.patch22
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c81f14d2a424
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = videosnarf
+ pkgdesc = A new security assessment tool for pcap analysis
+ pkgver = 0.63
+ pkgrel = 3
+ url = http://ucsniff.sourceforge.net/videosnarf.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpcap
+ depends = libnet
+ source = http://downloads.sourceforge.net/project/ucsniff/videosnarf/videosnarf-0.63.tar.gz
+ source = videosnarf-0.63-fix-linking.patch
+ md5sums = 19acd3bcb5c3912b1c5795b505f11958
+ md5sums = 78472de65f6d4e7e2e41f98624b28147
+
+pkgname = videosnarf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6092391a3f1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: M0Rf30
+
+pkgname=videosnarf
+pkgver=0.63
+pkgrel=3
+pkgdesc="A new security assessment tool for pcap analysis"
+arch=('i686' 'x86_64')
+url="http://ucsniff.sourceforge.net/videosnarf.html"
+license=('GPL')
+depends=('libpcap' 'libnet')
+source=(http://downloads.sourceforge.net/project/ucsniff/$pkgname/$pkgname-$pkgver.tar.gz
+ videosnarf-0.63-fix-linking.patch)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i ../videosnarf-0.63-fix-linking.patch
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+md5sums=('19acd3bcb5c3912b1c5795b505f11958'
+ '78472de65f6d4e7e2e41f98624b28147')
diff --git a/videosnarf-0.63-fix-linking.patch b/videosnarf-0.63-fix-linking.patch
new file mode 100644
index 000000000000..a4d183f96f42
--- /dev/null
+++ b/videosnarf-0.63-fix-linking.patch
@@ -0,0 +1,22 @@
+diff -Naur -x '*~' videosnarf-0.63/configure.in videosnarf-0.63-fix-linking/configure.in
+--- videosnarf-0.63/configure.in 2010-05-15 19:40:07.000000000 +0200
++++ videosnarf-0.63-fix-linking/configure.in 2012-02-29 19:33:27.516906867 +0100
+@@ -31,4 +31,6 @@
+ ;;
+ esac
+
++AC_CHECK_LIB(pcap, pcap_compile, , AC_MSG_ERROR(pcap libary required))
++
+ AC_OUTPUT(Makefile src/Makefile)
+diff -Naur -x '*~' videosnarf-0.63/src/Makefile.am videosnarf-0.63-fix-linking/src/Makefile.am
+--- videosnarf-0.63/src/Makefile.am 2010-05-15 19:40:07.000000000 +0200
++++ videosnarf-0.63-fix-linking/src/Makefile.am 2012-02-29 19:33:42.027725455 +0100
+@@ -10,8 +10,6 @@
+
+ #videosnarf_LDFLAGS = -lpcap -L../codec-lib -lG729a -lG7231 -lG726
+
+-videosnarf_LDFLAGS = -lpcap
+-
+ if ARCH_X32
+
+ videosnarf_LDADD = ../codec-lib/libG729a.a \