summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Bright2016-09-10 14:31:07 +0100
committerDan Bright2016-09-10 14:31:07 +0100
commitf2165567c57f8e0cec8ac39d38c4672361278b03 (patch)
tree5de192ad9d452b471d8cf010250d6e80dab73d4f
downloadaur-f2165567c57f8e0cec8ac39d38c4672361278b03.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f075721bc143
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Sep 10 13:18:31 UTC 2016
+pkgbase = videotagger
+ pkgdesc = NOTE: THIS IS BETA. USE AT YOUR OWN RISK. GTK 3.x research tool application to take timestamped tags/notes of streamed or locally played video clips. The application controls and uses MPV player.
+ pkgver = 0.1.1.r9
+ pkgrel = 1
+ url = https://github.com/ZWS2014/VideoTagger
+ arch = any
+ license = GPL3
+ depends = python>=3.0.0
+ depends = python-gobject
+ depends = git
+ depends = libyaml
+ depends = mpv
+ depends = python-pip
+ depends = python-yaml
+ source = VideoTagger::git+https://github.com/ZWS2014/VideoTagger
+ sha256sums = SKIP
+
+pkgname = videotagger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3b8c90cfe601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dan Bright <productions at zaziork dot com>
+pkgname=videotagger
+pkgrel=1 # package release (reset to 1 when new package version released (pkgver)
+pkgver=0.1.1.r9 # package version (increment when new application version released, but overwritten on build with pkgver() method below)
+pkgdesc="NOTE: THIS IS BETA. USE AT YOUR OWN RISK. GTK 3.x research tool application to take timestamped tags/notes of streamed or locally played video clips. The application controls and uses MPV player."
+arch=('any')
+url="https://github.com/ZWS2014/VideoTagger"
+license=('GPL3')
+depends=('python>=3.0.0' 'python-gobject' 'git' 'libyaml' 'mpv' 'python-pip' 'python-yaml')
+source=("VideoTagger::git+https://github.com/ZWS2014/VideoTagger")
+#source=($pkgname-$pkgver.tar.gz)
+sha256sums=('SKIP')
+pkgver() {
+cd "$srcdir/VideoTagger/VideoTagger"
+#printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+printf "%s.r%s" "$(cat VideoTagger/VERSION.rst)" "$(git rev-list --count HEAD)" # reading from included version file ensures version matches with the published PyPi package version
+}
+#prepare() {
+#}
+package() {
+mv $srcdir/VideoTagger/VideoTagger $srcdir/VideoTagger/VideoTagger-$pkgver
+cd "$srcdir/VideoTagger/VideoTagger-$pkgver"
+PIP_CONFIG_FILE=/dev/null
+pip install --root="$pkgdir/" --isolated "$srcdir/VideoTagger/VideoTagger-$pkgver/dist/"*.whl
+install -Dm644 "$srcdir/VideoTagger/VideoTagger-$pkgver/VideoTagger/resources/videotagger.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+install -Dm644 "$srcdir/VideoTagger/VideoTagger-$pkgver/VideoTagger/resources/videotagger_icon_256x256.png" "$pkgdir/usr/share/pixmaps/videotagger_icon_256x256.png"
+}
+post_install() {
+update-desktop-database -q
+}
+post_remove() {
+update-desktop-database -q
+}