summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Ortiz Manero2020-02-10 14:32:28 +0100
committerMario Ortiz Manero2020-02-10 14:32:28 +0100
commit1eeb7c9a3b09b41db0bf712e11d0743d43ea92df (patch)
tree50bc280885ab2a64cf7c79472ac0616d0214afd3
parent9a49db5e700b0352d472182a2106fe564aa23d6c (diff)
downloadaur-1eeb7c9a3b09b41db0bf712e11d0743d43ea92df.tar.gz
2.0.1 - desktop entry
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f219bd027526..856f65da0f77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vidify
pkgdesc = Watch live music videos for the songs playing on your device
- pkgver = 2.0
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/vidify/vidify
arch = any
@@ -21,8 +21,8 @@ pkgbase = vidify
depends = python-pyqtwebengine
depends = python-qtpy
optdepends = vidify-audiosync: audio synchronization extension
- source = https://github.com/vidify/vidify/archive/2.0.tar.gz
- md5sums = c83a9a17ce821b56e91c456f1bddc883
+ source = https://github.com/vidify/vidify/archive/2.0.1.tar.gz
+ md5sums = 69ca744d3adba0a6bee9230d3316aadb
pkgname = vidify
diff --git a/PKGBUILD b/PKGBUILD
index 3a9a61e23212..ba23349f2cc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mario O.M. <marioortizmanero@gmail.com>
pkgname=vidify
-pkgver=2.0
+pkgver=2.0.1
pkgrel=1
pkgdesc="Watch live music videos for the songs playing on your device"
arch=("any")
@@ -14,7 +14,7 @@ optdepends=("python-mpv: support for the mpv player")
optdepends=("vidify-audiosync: audio synchronization extension")
makedepends=("python-setuptools")
source=("https://github.com/vidify/vidify/archive/$pkgver.tar.gz")
-md5sums=('c83a9a17ce821b56e91c456f1bddc883')
+md5sums=('69ca744d3adba0a6bee9230d3316aadb')
build() {
cd "$pkgname-$pkgver"
@@ -24,4 +24,8 @@ build() {
package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # Installing the desktop file and icon
+ install -Dm755 "dev/vidify.desktop" "$pkgdir/usr/share/applications/vidify.desktop"
+ install -Dm644 "vidify/gui/res/icon.svg" "$pkgdir/usr/share/pixmaps/vidify.svg"
}