summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonny Lorenz2020-08-04 11:14:21 +0200
committerRonny Lorenz2020-08-04 11:14:21 +0200
commit1d20c31ba2d8d884482126fd01213467b658290e (patch)
tree7de5c35e87b7f11ef5329effa3cc1d522b19a77b
parente7b5f12d2d9b8aa1afb1fca3ffb3a3f386662100 (diff)
downloadaur-1d20c31ba2d8d884482126fd01213467b658290e.tar.gz
Fix compilation issues with GCC10
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-compilation-issues-with-GCC-10.patch46
-rw-r--r--PKGBUILD15
3 files changed, 60 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19065777436b..748264fa4645 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = viennarna
pkgdesc = RNA Secondary Structure Prediction and Comparison
pkgver = 2.4.14
- pkgrel = 1
+ pkgrel = 2
url = http://www.tbi.univie.ac.at/RNA
arch = x86_64
arch = i686
@@ -17,7 +17,9 @@ pkgbase = viennarna
options = staticlibs
options = !strip
source = http://www.tbi.univie.ac.at/RNA/packages/source/ViennaRNA-2.4.14.tar.gz
+ source = 0001-Fix-compilation-issues-with-GCC-10.patch
sha256sums = ba9cfc8a48e457fc891628f3229a3924de31714460dc4a4dec081868f802cc28
+ sha256sums = 4fb955d969b9a4c9fba7b3e7be7727c008454d1a2ea7ef5263ffc2544c0fe352
pkgname = viennarna
depends = perl
diff --git a/0001-Fix-compilation-issues-with-GCC-10.patch b/0001-Fix-compilation-issues-with-GCC-10.patch
new file mode 100644
index 000000000000..97f1f8776bf2
--- /dev/null
+++ b/0001-Fix-compilation-issues-with-GCC-10.patch
@@ -0,0 +1,46 @@
+From d1ec784dfae5b46fd70bd1fc49ec3c96e92edf6d Mon Sep 17 00:00:00 2001
+From: Ronny Lorenz <ronny@tbi.univie.ac.at>
+Date: Wed, 3 Jun 2020 10:13:13 +0200
+Subject: [PATCH] Fix compilation issues with GCC 10
+
+---
+ globals.c | 5 +++++
+ globals.h | 6 +++---
+ 2 files changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/globals.c b/globals.c
+index c1a8859..e5c1a4a 100644
+--- a/globals.c
++++ b/globals.c
+@@ -25,6 +25,11 @@
+ #include "globals.h"
+ #include "cmdline.h"
+
++
++GlobVars GSV;
++GlobArrays GAV;
++GlobToggles GTV;
++
+ /* forward declarations privat functions */
+ static void ini_globs(void);
+ static void ini_gtoggles (void);
+diff --git a/globals.h b/globals.h
+index 622c7db..eafd13c 100644
+--- a/globals.h
++++ b/globals.h
+@@ -88,9 +88,9 @@ void clean_up_globals(void);
+ void log_prog_params(FILE *FP);
+ void log_start_stop(FILE *FP);
+
+-GlobVars GSV;
+-GlobArrays GAV;
+-GlobToggles GTV;
++extern GlobVars GSV;
++extern GlobArrays GAV;
++extern GlobToggles GTV;
+
+ #endif
+
+--
+2.26.2
+
diff --git a/PKGBUILD b/PKGBUILD
index ae0d9b9b7146..dcb0d461792b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=viennarna
pkgname=('viennarna' 'python-rna' 'python2-rna' 'perl-rna')
pkgver=2.4.14
-pkgrel=1
+pkgrel=2
pkgdesc="RNA Secondary Structure Prediction and Comparison"
arch=('x86_64' 'i686')
license=('Custom')
@@ -16,18 +16,25 @@ makedepends=( 'perl'
'check'
'mpfr'
'gsl')
-source=(http://www.tbi.univie.ac.at/RNA/packages/source/ViennaRNA-${pkgver}.tar.gz)
+source=(http://www.tbi.univie.ac.at/RNA/packages/source/ViennaRNA-${pkgver}.tar.gz
+ '0001-Fix-compilation-issues-with-GCC-10.patch')
options=('staticlibs' '!strip')
-sha256sums=('ba9cfc8a48e457fc891628f3229a3924de31714460dc4a4dec081868f802cc28')
+sha256sums=('ba9cfc8a48e457fc891628f3229a3924de31714460dc4a4dec081868f802cc28'
+ '4fb955d969b9a4c9fba7b3e7be7727c008454d1a2ea7ef5263ffc2544c0fe352')
-build() {
+prepare() {
cd "${srcdir}/ViennaRNA-${pkgver}"
+ patch -d src/Kinfold -p1 -i "${srcdir}/0001-Fix-compilation-issues-with-GCC-10.patch"
./configure \
--with-cluster \
--with-kinwalker \
--prefix=/usr \
INSTALLDIRS=vendor
+}
+
+build() {
+ cd "${srcdir}/ViennaRNA-${pkgver}"
make
}