summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112018-07-27 10:30:59 +0200
committerjose17112018-07-27 10:30:59 +0200
commit20b5f82b38ca1f56a2049b458ee480e5b848be91 (patch)
tree3c296852c5a30da00307eb657738c63a9f21a98c
downloadaur-20b5f82b38ca1f56a2049b458ee480e5b848be91.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32910e2f8a68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jul 27 08:30:47 UTC 2018
+pkgbase = vifm-colors-git
+ pkgdesc = Various colorschemes for vifm file explorer
+ pkgver = r51.d9b39e8
+ pkgrel = 1
+ url = https://github.com/vifm/vifm-colors
+ arch = any
+ license = GPL
+ makedepends = git
+ conflicts = vifm-colors
+ source = vifm-colors-git::git+https://github.com/vifm/vifm-colors.git
+ md5sums = SKIP
+
+pkgname = vifm-colors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2de2d574f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=vifm-colors-git
+_pkgname=vifm-colors
+pkgver=r51.d9b39e8
+pkgrel=1
+pkgdesc="Various colorschemes for vifm file explorer"
+url="https://github.com/vifm/vifm-colors"
+makedepends=('git')
+conflicts=(vifm-colors)
+license=('GPL')
+arch=('any')
+source=("${pkgname}"::'git+https://github.com/vifm/vifm-colors.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ for i in *.vifm
+ do
+ install -Dm644 "$i" "$pkgdir/usr/share/vifm/colors/$i"
+ done
+}
+
+# vim:set ts=2 sw=2 et: