summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Galindo2021-09-03 12:44:12 +0200
committerCarlos Galindo2021-09-03 12:44:12 +0200
commitbc42e32c5a4798dbc1fd4a0a1a4ac2919ead65ee (patch)
tree7e1ee5a8f53829e2744e0dc7f2129c43045bf4e0
parent64e22da42cd1a6fbc03f22f0678ae9c45f002081 (diff)
downloadaur-bc42e32c5a4798dbc1fd4a0a1a4ac2919ead65ee.tar.gz
change build process to match best practices (see wiki)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6285a39c5085..0b4481275cea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vigil
pkgdesc = Microservices Status Page. Monitors a distributed infrastructure and sends alerts (Slack, SMS, etc.).
pkgver = 1.22.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/valeriansaliou/vigil
arch = x86_64
arch = armv7h
diff --git a/PKGBUILD b/PKGBUILD
index e931a7d64203..53c546c7c690 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=vigil
pkgver=1.22.1
-pkgrel=1
+pkgrel=2
pkgdesc="Microservices Status Page. Monitors a distributed infrastructure and sends alerts (Slack, SMS, etc.)."
arch=("x86_64" "armv7h")
url="https://github.com/valeriansaliou/vigil"
@@ -21,16 +21,20 @@ sha512sums=('a437e0a11d0b4fed3d1d2fe78180811e9dec1145bf0fb7920c666c167c5d956fbf4
prepare() {
cd "$pkgname-$pkgver"
sed -i 's|path = "./res/assets/"|path = "/usr/share/vigil/"|g' config.cfg
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
cd "$pkgname-$pkgver"
- cargo build --release --locked --all-features --target-dir=target
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
}
check() {
cd "$pkgname-$pkgver"
- cargo test --release --locked --all-features --target-dir=target
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
}
package() {