summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2018-11-28 11:57:58 +0300
committerNikolay Korotkiy2018-11-28 11:57:58 +0300
commit60cf987af1b2b9a4052f408ba157618ce9ba8b94 (patch)
treebc7764109930ddbac36eee728536da832a697c6c
parent3f73134114a89c8bf6d31a40da60d9e7838a74d7 (diff)
downloadaur-60cf987af1b2b9a4052f408ba157618ce9ba8b94.tar.gz
Fix url
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1750016f652f..abe102b7efb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by makepkg 5.1.1
-# Thu Sep 20 10:38:19 UTC 2018
+# Wed Nov 28 08:56:55 UTC 2018
pkgbase = viking-git
pkgdesc = GTK+2 application to manage GPS data
- pkgver = 1.6.2.r3307.2a5bafd2
+ pkgver = 1.6.2.r3348.6bce9451
pkgrel = 1
- url = http://viking-gps.github.io/
+ url = https://viking-gps.github.io/
arch = i686
arch = x86_64
license = GPL2
@@ -20,7 +20,7 @@ pkgbase = viking-git
depends = mapnik
depends = liboauth
optdepends = gpsbabel: import and export GPS tracks from various formats
- provides = viking=1.6.2.r3307.2a5bafd2
+ provides = viking=1.6.2.r3348.6bce9451
conflicts = viking
source = https://github.com/viking-gps/viking/archive/master.tar.gz
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 575d68c4c243..7f7412847398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ _pkgname=viking
_branch=master
_use_gh_api=true
pkgname=${_pkgname}-git
-pkgver=1.6.2.r3307.2a5bafd2
+pkgver=1.6.2.r3348.6bce9451
pkgrel=1
-pkgdesc="GTK+2 application to manage GPS data"
+pkgdesc='GTK+2 application to manage GPS data'
arch=('i686' 'x86_64')
-url="http://viking-gps.github.io/"
+url='https://viking-gps.github.io/'
license=('GPL2')
depends=('curl' 'file' 'gpsd' 'gtk2' 'libgexiv2' 'mapnik' 'liboauth')
makedepends=('boost' 'gnome-doc-utils' 'intltool')
@@ -35,12 +35,12 @@ pkgver() {
if [ "${_use_gh_api}" = true ]; then
api_url="https://api.github.com/repos/${_orgname}/${_pkgname}"
- base="029f2f53"
- head=$(curl -s "$api_url/git/refs/heads/${_branch}" | \
+ base='029f2f53'
+ head=$(curl -s "${api_url}/git/refs/heads/${_branch}" | \
python -c "import sys, json; print(json.load(sys.stdin)['object']['sha'][:8])")
- count=$(curl -s "$api_url/compare/${base}...${head}" | \
+ count=$(curl -s "${api_url}/compare/${base}...${head}" | \
python -c "import sys, json; print(json.load(sys.stdin)['total_commits'] + 1)")
- release=$(curl -s "$api_url/tags" | \
+ release=$(curl -s "${api_url}/tags" | \
python -c "import sys, json; r = json.load(sys.stdin)[0]; print(r['name'])")
else
release="$(git describe --tags $(git rev-list --tags --max-count=1))"