summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-06-23 16:15:37 -0500
committerlibele2022-06-23 16:15:37 -0500
commit42e5b7d2431d2e6f917f23cee41186f1137b3692 (patch)
tree1a51f75f3745a7ea00f7401f5fc66da9ac67d26c
parentf484f7b095fa27fcac94b6baaa6bc416839a891f (diff)
downloadaur-42e5b7d2431d2e6f917f23cee41186f1137b3692.tar.gz
version 1.0.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 073bfb5ddeb8..c7e890bc541b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = vilearn
pkgdesc = An interactive vi tutorial.
- pkgver = 1.0
- pkgrel = 7
+ pkgver = 1.0.1
+ pkgrel = 1
url = https://web.archive.org/web/20020806204039/http://vilearn.org/
arch = any
- license = custom
+ license = custom:Copyright (c) 1992 Jill Kliger and Wesley Craig
+ optdepends = vi: the original ex/vi text editor
source = https://archive.org/download/vilearn/vilearn-1.0.tar.gz
- source = https://archive.org/download/vilearn/vilearn.diff
+ source = https://tildegit.org/libele/vilearn/archive/vilearn-1.0.1.tar.gz
md5sums = 8fd3b72e5eb1e4dce1870e7b3becbeab
- md5sums = 39975f4064c59c30545f6f070fc85cc6
+ md5sums = fdfba9fde37af73cbde0f83724cd3713
pkgname = vilearn
diff --git a/PKGBUILD b/PKGBUILD
index 28b2ac87a3b3..bda56e820d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# maintainer: libele <libele@disroot.org>
pkgname=vilearn
-pkgver=1.0
-pkgrel=7
+pkgver=1.0.1
+pkgrel=1
pkgdesc="An interactive vi tutorial."
-url="https://web.archive.org/web/20020806204039/http://vilearn.org/"
-license=('custom')
arch=('any')
+url="https://web.archive.org/web/20020806204039/http://vilearn.org/"
+license=('custom:Copyright (c) 1992 Jill Kliger and Wesley Craig')
+optdepends=('vi: the original ex/vi text editor')
-source=("https://archive.org/download/vilearn/vilearn"{-1.0.tar.gz,.diff})
+source=('https://archive.org/download/vilearn/vilearn-1.0.tar.gz'
+ "https://tildegit.org/libele/vilearn/archive/vilearn-$pkgver.tar.gz")
md5sums=('8fd3b72e5eb1e4dce1870e7b3becbeab'
- '39975f4064c59c30545f6f070fc85cc6')
+ 'fdfba9fde37af73cbde0f83724cd3713')
package() {
cd "${srcdir}"
- patch -d vilearn-1.0 < vilearn.diff
+ patch -d vilearn-1.0 < vilearn/vilearn-1.0.1.patch
cd vilearn-1.0
make DESTDIR=${pkgdir} install
install -Dm644 README "${pkgdir}"/usr/share/vilearn
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/vilearn/LICENSE
}