summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2016-02-02 17:24:53 +1100
committerRhinoceros2016-02-02 17:24:53 +1100
commite53ba204eb1e0fb0203823af084218cf6757824e (patch)
tree0bcdc88430153b9bba049b9e9af3567c5d34de58
parent418995b39b50f7a9d0f782d7711b2a5d5960f392 (diff)
downloadaur-e53ba204eb1e0fb0203823af084218cf6757824e.tar.gz
Update to 0.7.r217.g8c860b7-2
* Update url * Add group, depends and optdepends (vim-airline-themes-git) * Clean code: remove custom variables, NOP and fix style
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 902008efdd28..6e6efb7a3dcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
# Generated by mksrcinfo v8
-# Sun Jan 31 19:19:07 UTC 2016
+# Tue Feb 2 06:24:39 UTC 2016
pkgbase = vim-airline-git
pkgdesc = A lean & mean statusline for vim that's light as air.
pkgver = 0.7.r217.g8c860b7
- pkgrel = 1
+ pkgrel = 2
epoch = 1
- url = https://github.com/bling/vim-airline
+ url = https://github.com/vim-airline/vim-airline
install = airline.install
arch = any
+ groups = vim-plugins
license = GPL
makedepends = git
- optdepends = otf-powerline-symbols-git: Use the Powerline symbols
+ depends = vim
+ optdepends = otf-powerline-symbols-git: use the Powerline symbols
+ optdepends = vim-airline-themes-git: alternative themes
provides = vim-airline
conflicts = vim-airline
- source = airline::git+https://github.com/bling/vim-airline.git#branch=master
+ source = git+https://github.com/vim-airline/vim-airline.git
md5sums = SKIP
pkgname = vim-airline-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 1fe2f7a2ed8e..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-src/
-pkg/
-*.tar.*
-airline
diff --git a/PKGBUILD b/PKGBUILD
index f64285b7d28c..3f64d3cb8d02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Ariel Popper <a@arielp.com>
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Ariel Popper <a@arielp.com>
+
pkgname=vim-airline-git
pkgver=0.7.r217.g8c860b7
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="A lean & mean statusline for vim that's light as air."
-arch=(any)
-url="https://github.com/bling/vim-airline"
+arch=('any')
+url='https://github.com/vim-airline/vim-airline'
license=('GPL')
+depends=('vim')
+makedepends=('git')
conflicts=('vim-airline')
provides=('vim-airline')
-optdepends=('otf-powerline-symbols-git: Use the Powerline symbols')
-makedepends=('git')
-install=airline.install
+groups=('vim-plugins')
+optdepends=('otf-powerline-symbols-git: use the Powerline symbols'
+ 'vim-airline-themes-git: alternative themes')
+install='airline.install'
md5sums=('SKIP')
-_gitname=airline
-_gitbranch=master
-source=("${_gitname}::git+https://github.com/bling/vim-airline.git#branch=${_gitbranch}")
+source=("git+https://github.com/vim-airline/${pkgname%-git}.git")
pkgver() {
- cd "${srcdir}/${_gitname}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "${pkgname%-git}"
local vimfiles="${pkgdir}/usr/share/vim/vimfiles"
mkdir -p "${vimfiles}"
cp -r autoload doc plugin t "${vimfiles}"
}
-
-# vim:set ts=2 sw=2 et: