summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaiting Chen2011-01-25 23:54:47 +0000
committerKaiting Chen2011-01-25 23:54:47 +0000
commit577ebce8ebd0b49b525e10f4a389b3dd3e3bc37b (patch)
tree37a72b1ca1edc484241f7b2acf54b51e2799d188
downloadaur-577ebce8ebd0b49b525e10f4a389b3dd3e3bc37b.tar.gz
Initial commit of vim-align
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD26
-rw-r--r--vimdoc.install21
3 files changed, 54 insertions, 0 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..83e39a63ba6d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright (C) 1999-2007 Charles E. Campbell, Jr.
+Permission is hereby granted to use and distribute this code, with or without
+modifications, provided that this copyright notice is copied with it. Like
+anything else that's free, Align.vim is provided *as is* and comes with no
+warranty of any kind, either expressed or implied. By using this plugin, you
+agree that in no event will the copyright holder be liable for any damages
+resulting from the use of this software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c36482b1763a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor : vti <viacheslav.t at gmail dot com>
+
+pkgname=vim-align
+pkgver=35.41
+_scriptid='10110'
+pkgrel=5
+pkgdesc='Lets you align lines using regular expressions'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=294'
+license=('GPL')
+depends=('vim')
+install=vimdoc.install
+source=("$pkgname.vbz.gz::http://www.vim.org/scripts/download_script.php?src_id=$_scriptid"
+ 'LICENSE')
+md5sums=('423eb712431d4de22a8790fb145b7053'
+ 'b924ab4f0d09585ac4482208cc32bd2f')
+
+build() {
+ install -dm755 "${pkgdir}/usr/share/vim/vimfiles"
+ cd "${pkgdir}/usr/share/vim/vimfiles"
+
+ /usr/bin/vim -n -i NONE -c ":UseVimball `pwd`" -c ":q" $srcdir/$pkgname.vbz
+ rm -f '.VimballRecord' 'doc/tags'
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..63d262b1ef0a
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,21 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins \
+ -u NONE -U NONE \
+ --cmd ':helptags /usr/share/vim/vimfiles/doc' \
+ --cmd ':q' > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*