summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Gautier2021-02-06 20:33:38 +0100
committerMax Gautier2021-02-06 20:33:38 +0100
commitd6768caf5195db92a0e145a17bc2247de915db70 (patch)
tree892e9b775f6baecb2ec37cc2dd0a487b74b14af2
parent4f21a4647a9dab871016bfa6dfebd39e3c17e3a6 (diff)
downloadaur-d6768caf5195db92a0e145a17bc2247de915db70.tar.gz
Adjustements
Use git in makedepends Use tags for versions Use Github gpg key for source integrity
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dd953b78c40..cea57f3f5ce7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = vim-asyncomplete-git
pkgdesc = Async autocompletion for Vim 8 and Neovim with timers
- pkgver = r170.5713fa6
+ pkgver = 2.1.0.r27.g4be3c16
pkgrel = 1
url = https://github.com/prabirshrestha/asyncomplete.vim.git
arch = any
groups = vim-plugins
license = MIT
+ makedepends = git
depends = vim
- source = asyncomplete.vim::git+https://github.com/prabirshrestha/asyncomplete.vim.git
+ source = git+https://github.com/prabirshrestha/asyncomplete.vim.git?signed
+ validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
sha512sums = SKIP
pkgname = vim-asyncomplete-git
diff --git a/PKGBUILD b/PKGBUILD
index 6cfbd01cb253..2ac2e84bdb76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
-# Maintainer: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
+# Maintainer: Max Gautier <mg+archlinux@max.gautier.name>
+# Contributor: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
# Contributor: Rodrigo Gryzinski <rogryza@gmail.com>
_pkgname=asyncomplete.vim
pkgname=vim-asyncomplete-git
-pkgver=r170.5713fa6
+pkgver=2.1.0.r27.g4be3c16
pkgrel=1
pkgdesc="Async autocompletion for Vim 8 and Neovim with timers"
arch=('any')
url="https://github.com/prabirshrestha/${_pkgname}.git"
license=('MIT')
depends=('vim')
+makedepends=('git')
groups=('vim-plugins')
-source=("${_pkgname}::git+$url")
+source=("git+$url?signed")
sha512sums=('SKIP')
+validpgpkeys=('5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23') # Github key
pkgver()
{
- cd "$srcdir/$_pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "$_pkgname"
+ git describe --tags | tail --bytes +2 | sed -e 's/-/.r/' -e 's/-/./'
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
# Install license when available
install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"