summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2019-06-16 21:57:00 +0200
committerKrzysztof AS (3ED)2019-06-16 21:57:00 +0200
commitf1f420bddc9d633200ad9029ce01c4abff012b1c (patch)
tree58c6a7e6e32d68163671cb903e93644766e4cc70
parentcef68c4b8dac5711ba50dad47e3bcc40e4fa4b29 (diff)
downloadaur-vim-bash-support.tar.gz
upgrade
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
-rw-r--r--vimdoc.install24
3 files changed, 27 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2960da7d565e..6c50ee81c601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = vim-bash-support
pkgdesc = BASH-IDE - Write and run BASH-scripts using menus and hotkeys.
- pkgver = 4.2.1
+ pkgver = 4.3
pkgrel = 1
- url = http://vim.sourceforge.net/scripts/script.php?script_id=365
- install = vimdoc.install
+ url = https://www.vim.org/scripts/script.php?script_id=365
arch = any
license = custom:vim
- depends = vim-vim-support
+ depends = vim-vim-support>=2.4
optdepends = bashdb: bash debugger
- noextract = vim-bash-support-4.2.1.zip
- source = vim-bash-support-4.2.1.zip::http://www.vim.org/scripts/download_script.php?src_id=21804
- sha256sums = 67aab863783dd72ba9a963b3e2c0e1754cd93795cf661fdeb5e699b1b3841742
+ noextract = vim-bash-support-4.3.zip
+ source = vim-bash-support-4.3.zip::http://www.vim.org/scripts/download_script.php?src_id=24452
+ sha256sums = f63cd5ec6989e80618e5170f820e67a9256047426783cbbccb56aaddefdd44ae
pkgname = vim-bash-support
diff --git a/PKGBUILD b/PKGBUILD
index dc09173d766a..dbb914d87e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,36 @@
# Maintainer: 3ED <krzysztof1987 _at_ gmail _dot_ com>
pkgname=vim-bash-support
-pkgver=4.2.1
-_srcid=21804
+pkgver=4.3
+_srcid=24452
pkgrel=1
pkgdesc='BASH-IDE - Write and run BASH-scripts using menus and hotkeys. '
arch=('any')
-url='http://vim.sourceforge.net/scripts/script.php?script_id=365'
+url='https://www.vim.org/scripts/script.php?script_id=365'
license=('custom:vim')
-depends=('vim-vim-support')
+depends=('vim-vim-support>=2.4')
optdepends=('bashdb: bash debugger')
-install='vimdoc.install'
source=("${pkgname}-${pkgver}.zip::http://www.vim.org/scripts/download_script.php?src_id=$_srcid")
+sha256sums=('f63cd5ec6989e80618e5170f820e67a9256047426783cbbccb56aaddefdd44ae')
noextract=("${pkgname}-${pkgver}.zip")
-sha256sums=('67aab863783dd72ba9a963b3e2c0e1754cd93795cf661fdeb5e699b1b3841742')
package() {
- _DESTDIR="$pkgdir"/usr/share/vim/vimfiles
+ cd "$srcdir"
+ _DESTDIR="$pkgdir"/usr/share/vim/vimfiles
- install -dm755 "${_DESTDIR}"
- bsdtar -xf ${pkgname}-${pkgver}.zip -C "${_DESTDIR}" \
- --exclude "autoload/mmtemplates/core.vim" \
- --exclude "doc/templatesupport.txt" \
- --exclude "syntax/template.vim"
+ install -dm755 "${_DESTDIR}"
- # Fix perms
- chmod -R a=r,a+X,u+w "${_DESTDIR}"
+ bsdtar -xf ${pkgname}-${pkgver}.zip \
+ --exclude "autoload/mmtemplates/core.vim" \
+ --exclude "autoload/mmtemplates/config.vim" \
+ --exclude "autoload/mmtemplates/wizard.vim" \
+ --exclude "doc/templatesupport.txt" \
+ --exclude "ftdetect/template.vim" \
+ --exclude "ftplugin/template.vim" \
+ --exclude "syntax/template.vim" \
+ --directory "${_DESTDIR}"
+
+ # note: exclusions should be included inside vim-vim-support
+
+ chmod -R a=r,a+X,u+w "${_DESTDIR}"
}
diff --git a/vimdoc.install b/vimdoc.install
deleted file mode 100644
index 488184f0c2cb..000000000000
--- a/vimdoc.install
+++ /dev/null
@@ -1,24 +0,0 @@
-vimdocinstall() {
- echo -n "updating Vim help tags... "
- usr/bin/vim --noplugin -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
- echo "done."
-}
-
-
-post_install() {
- vimdocinstall
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- vimdocinstall
-}
-
-op=$1
-shift
-
-$op $*