summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 12:05:21 +1000
committerJonathan Liu2015-06-19 12:05:21 +1000
commitb8d92b30330968ec45c5e842bb1bca8c2846bb2f (patch)
tree51aef8b5d37c736f08264fa0dbcbb60ef27d9de2
downloadaur-b8d92b30330968ec45c5e842bb1bca8c2846bb2f.tar.gz
Initial import
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
3 files changed, 52 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..841fffbf6d18
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = vim-bitbake-git
+ pkgdesc = Vim files for the BitBake tool
+ pkgver = r50.d601f51
+ pkgrel = 1
+ url = https://github.com/kergoth/vim-bitbake
+ arch = any
+ license = MIT
+ depends = vim
+ source = git+https://github.com/kergoth/vim-bitbake.git
+
+pkgname = vim-bitbake-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb30cb9f6565
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vim-bitbake-git
+ pkgdesc = Vim files for the BitBake tool
+ pkgver = r50.d601f51
+ pkgrel = 1
+ url = https://github.com/kergoth/vim-bitbake
+ arch = any
+ license = MIT
+ depends = vim
+ source = git+https://github.com/kergoth/vim-bitbake.git
+ md5sums = SKIP
+
+pkgname = vim-bitbake-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2be8176827e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=vim-bitbake-git
+pkgver=r50.d601f51
+_gitname=vim-bitbake
+pkgrel=1
+pkgdesc="Vim files for the BitBake tool"
+arch=('any')
+url="https://github.com/kergoth/vim-bitbake"
+license=('MIT')
+depends=('vim')
+source=('git+https://github.com/kergoth/vim-bitbake.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_gitname"
+ install -Dm644 ftdetect/bitbake.vim "$pkgdir/usr/share/vim/vimfiles/ftdetect/bitbake.vim"
+ install -Dm644 ftplugin/bitbake.vim "$pkgdir/usr/share/vim/vimfiles/ftplugin/bitbake.vim"
+ install -Dm644 plugin/newbb.vim "$pkgdir/usr/share/vim/vimfiles/plugin/newbb.vim"
+ install -Dm644 syntax/bitbake.vim "$pkgdir/usr/share/vim/vimfiles/syntax/bitbake.vim"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}