summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:47:16 +0200
committerPiotr Rogoża2015-06-14 16:47:16 +0200
commit624d559ffcee8fcfba25476e295cbb86ae9e047b (patch)
tree4d1fc4379a8ae04ca1520e0e3b861e324f003b69
downloadaur-vim-c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--vimdoc.install23
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd52143511a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-c
+ pkgdesc = C/C++ IDE -- Write and run programs. Insert statements, idioms, comments etc.
+ pkgver = 6.1.1
+ pkgrel = 2
+ url = http://www.vim.org/scripts/script.php?script_id=213
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = GPL2
+ depends = vim-vim-support>=2.3
+ provides = vim-c-support
+ source = vim-c-6.1.1.zip::http://www.vim.org/scripts/download_script.php?src_id=21803
+ sha256sums = 431a24b4548ed74314f517daca18e687a6b6ed39ef40a5df2fee77e2468bd663
+
+pkgname = vim-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf5ad95210c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Karl Kochs <captainhaggy @ i2pmail dot org>
+# Contributor: Laszlo Papp <djszapi @ gmail at com>
+
+pkgname=vim-c
+provides=(vim-c-support)
+pkgver=6.1.1
+_scriptid=21803
+pkgrel=2
+pkgdesc="C/C++ IDE -- Write and run programs. Insert statements, idioms, comments etc."
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=213'
+license=('GPL2')
+depends=('vim-vim-support>=2.3')
+groups=('vim-plugins')
+install='vimdoc.install'
+source=($pkgname-$pkgver.zip::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+package() {
+ cd "$srcdir"
+ _vim_dir='usr/share/vim/vimfiles'
+
+ install -d ${pkgdir}/${_vim_dir}
+
+ tar -c ./ \
+ --exclude $pkgname-$pkgver.zip \
+ --exclude autoload/mmtemplates/core.vim \
+ --exclude doc/templatesupport.txt \
+ --exclude syntax/template.vim \
+ | tar -x -C ${pkgdir}/${_vim_dir}
+}
+sha256sums=('431a24b4548ed74314f517daca18e687a6b6ed39ef40a5df2fee77e2468bd663')
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..66a417cca8ea
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,23 @@
+vimdocinstall() {
+ echo -n "updating Vim help tags... "
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_install() {
+ vimdocinstall
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*