summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:45:59 +0200
committerDaniel Nagy2015-06-08 19:45:59 +0200
commit2067a7a6307c8b578a864c9119011d56760546c5 (patch)
tree250f41918490f7da28da50d2981b3fc40a5fbf70
downloadaur-2067a7a6307c8b578a864c9119011d56760546c5.tar.gz
import to aur4
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD24
-rwxr-xr-xlicense.txt8
-rwxr-xr-xvimdoc.install19
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fbd62963840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-cabal
+ pkgdesc = Syntax coloration for Cabal
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2625
+ install = vimdoc.install
+ arch = i686
+ arch = x86_64
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = cabal.vim::http://www.vim.org/scripts/download_script.php?src_id=16755
+ source = license.txt
+ md5sums = 6e93a324d4d57e0e56aac949f93d0c0c
+ md5sums = efbd5986e691ce8c876fb86e8f5961ea
+
+pkgname = vim-cabal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..76f40c66c6a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Laszlo Papp <djszapi @ gmail at com>
+
+pkgname=vim-cabal
+pkgver=1.4
+_scriptid=16755
+pkgrel=1
+pkgdesc="Syntax coloration for Cabal"
+arch=('i686' 'x86_64')
+url="http://www.vim.org/scripts/script.php?script_id=2625"
+license=('custom')
+depends=(vim)
+groups=('vim-plugins')
+install=vimdoc.install
+source=(cabal.vim::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}
+ license.txt)
+md5sums=('6e93a324d4d57e0e56aac949f93d0c0c'
+ 'efbd5986e691ce8c876fb86e8f5961ea')
+
+build() {
+ install -Dm644 "$srcdir/cabal.vim" "$pkgdir/usr/share/vim/vimfiles/syntax/cabal.vim"
+ install -Dm755 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
+
diff --git a/license.txt b/license.txt
new file mode 100755
index 000000000000..226f27b5356b
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2002-2007 Yegappan Lakshmanan
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+taglist.vim is provided *as is* and comes with no warranty of any
+kind, either expressed or implied. In no event will the copyright
+holder be liable for any damamges resulting from the use of this
+software.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100755
index 000000000000..5246e5c21134
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*