summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-12 22:01:39 -0500
committerLuis Martinez2021-05-12 22:02:46 -0500
commitc42cf6c96e01b4154857df1cbf2608c8b7cca57b (patch)
tree5b7cc6b92871ced4d2b9304331fd5927fe97a73a
downloadaur-c42cf6c96e01b4154857df1cbf2608c8b7cca57b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..074c21383eeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-caw
+ pkgdesc = A vim comment plugin supporting operator/non-operator mappings, 300+ filetypes
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/tyru/caw.vim
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ depends = vim-plugin-runtime
+ optdepends = vim-repeat
+ source = vim-caw-1.1.1.tar.gz::https://github.com/tyru/caw.vim/archive/refs/tags/v1.1.1.tar.gz
+ sha256sums = e47348e9c13f0a8e5113c27db4be6cff4e38b63d405dbfa2e2393c3ff6229fed
+
+pkgname = vim-caw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76600b8e5540
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-caw
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="A vim comment plugin supporting operator/non-operator mappings, 300+ filetypes"
+arch=('any')
+url="https://github.com/tyru/caw.vim"
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+optdepends=('vim-repeat')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('e47348e9c13f0a8e5113c27db4be6cff4e38b63d405dbfa2e2393c3ff6229fed')
+
+package() {
+ cd "caw.vim-$pkgver"
+ find after autoload doc macros plugin \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}