summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author64-bitman2024-07-22 17:41:07 -0400
committer64-bitman2024-07-22 17:41:07 -0400
commit2879a1a362bfea7a92baa1ba024519052b69d3b6 (patch)
treefb885ca6ff3f650d0621e3c7154521d62f008267
downloadaur-2879a1a362bfea7a92baa1ba024519052b69d3b6.tar.gz
intial commit
-rw-r--r--.SRCINFO55
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD155
-rw-r--r--archlinux.vim46
-rw-r--r--vimdoc.hook11
-rw-r--r--vimrc18
6 files changed, 289 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..866c5359a547
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,55 @@
+pkgbase = vim-cli-git
+ pkgdesc = Vi Improved, a highly configurable, improved version of the vi text editor (cli version with X11 support)
+ pkgver = 9.1.0610
+ pkgrel = 1
+ url = https://www.vim.org
+ arch = x86_64
+ license = custom:vim
+ makedepends = gawk
+ makedepends = git
+ makedepends = glibc
+ makedepends = gpm
+ makedepends = libcanberra
+ makedepends = libgcrypt
+ makedepends = libxt
+ makedepends = lua
+ makedepends = perl
+ makedepends = python
+ makedepends = zlib
+ source = git+https://github.com/vim/vim.git
+ source = vimrc
+ source = archlinux.vim
+ source = vimdoc.hook
+ sha256sums = SKIP
+ sha256sums = b16e85e457397ab2043a7ee0a3c84307c6b4eac157fd0b721694761f25b3ed5b
+ sha256sums = cc3d931129854c298eb22e993ec14c2ad86cc1e70a08a64496f5e06559289972
+ sha256sums = 8e9656934d9d7793063230d15a689e10455e6db9b9fe73afa0f294792795d8ae
+
+pkgname = vim-cli-git
+ depends = vim-cli-git-runtime
+ depends = gpm
+ depends = acl
+ depends = glibc
+ depends = libgcrypt
+ depends = zlib
+ optdepends = python: Python language support
+ optdepends = lua: Lua language support
+ optdepends = perl: Perl language support
+ optdepends = cscope: cscope interface
+ provides = vim
+ provides = xxd
+ provides = vim-minimal
+ provides = vim-plugin-runtime
+ conflicts = gvim
+ conflicts = vim-minimal
+ conflicts = vim
+ replaces = vim-minimal
+
+pkgname = vim-cli-git-runtime
+ pkgdesc = Vi Improved, a highly configurable, improved version of the vi text editor (cli version with X11 support) (shared runtime)
+ optdepends = sh: support for some tools and macros
+ optdepends = python: demoserver example tool
+ optdepends = gawk: mve tools upport
+ provides = vim-runtime
+ conflicts = vim-runtime
+ backup = etc/vimrc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2565a729c24e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+vim/
+vim-cli-git-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..695b78e35a5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,155 @@
+# Maintainer: 64bitman <60551350+64-bitman@users.noreply.github.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Morten Linderud <foxboron@archlinux.org>
+# Contributor: T.J. Townsend <blakkheim@archlinux.org>
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Thomas Dziedzic <gostrc@gmail.com>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: tobias [ tobias at archlinux org ]
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+
+pkgbase=vim-cli-git
+pkgname=('vim-cli-git' 'vim-cli-git-runtime')
+pkgver=9.1.0610
+pkgrel=1
+pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (cli version with X11 support)'
+url='https://www.vim.org'
+arch=('x86_64')
+license=('custom:vim')
+makedepends=(
+ gawk
+ git
+ glibc
+ gpm
+ libcanberra
+ libgcrypt
+ libxt
+ lua
+ perl
+ python
+ zlib
+)
+source=(git+https://github.com/vim/vim.git
+ vimrc
+ archlinux.vim
+ vimdoc.hook)
+sha256sums=('SKIP'
+'b16e85e457397ab2043a7ee0a3c84307c6b4eac157fd0b721694761f25b3ed5b'
+'cc3d931129854c298eb22e993ec14c2ad86cc1e70a08a64496f5e06559289972'
+'8e9656934d9d7793063230d15a689e10455e6db9b9fe73afa0f294792795d8ae')
+
+prepare() {
+ (cd vim/src
+ # define the place for the global (g)vimrc file (set to /etc/vimrc)
+ sed -E 's|^.*(#define SYS_.*VIMRC_FILE.*").*$|\1|g' -i feature.h
+ sed -E 's|^.*(#define VIMRC_FILE.*").*$|\1|g' -i feature.h
+ autoconf
+ )
+}
+
+pkgver() {
+ (cd vim
+ git describe --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ )
+}
+
+build() {
+ msg2 "Building vim..."
+ (cd vim
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/var/lib/vim \
+ --with-features=huge \
+ --with-compiledby='Arch Linux User Repository' \
+ --enable-gpm \
+ --enable-acl \
+ --with-x=yes \
+ --disable-gui \
+ --enable-multibyte \
+ --enable-cscope \
+ --disable-netbeans \
+ --enable-perlinterp=dynamic \
+ --enable-python3interp=dynamic \
+ --enable-luainterp=dynamic \
+ --enable-autoservername \
+ --enable-canberra \
+ --disable-darwin \
+ --enable-fail-if-missing
+ make
+ )
+}
+
+package_vim-cli-git-runtime() {
+ pkgdesc+=' (shared runtime)'
+ optdepends=('sh: support for some tools and macros'
+ 'python: demoserver example tool'
+ 'gawk: mve tools upport')
+ backup=('etc/vimrc')
+ provides=('vim-runtime')
+ conflicts=('vim-runtime')
+
+ cd vim
+
+ make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+ # man and bin files belong to 'vim'
+ rm -r "${pkgdir}"/usr/share/man/ "${pkgdir}"/usr/bin/
+
+ # Don't forget logtalk.dict
+ install -Dm 644 runtime/ftplugin/logtalk.dict \
+ "${pkgdir}"/usr/share/vim/vim${_versiondir}/ftplugin/logtalk.dict
+
+ # rc files
+ install -Dm 644 "${srcdir}"/vimrc "${pkgdir}"/etc/vimrc
+ install -Dm 644 "${srcdir}"/archlinux.vim \
+ "${pkgdir}"/usr/share/vim/vimfiles/archlinux.vim
+
+ # no desktop files and icons
+ rm -r "${pkgdir}"/usr/share/{applications,icons}
+
+ # license
+ install -dm 755 "${pkgdir}"/usr/share/licenses/vim-runtime
+ ln -s /usr/share/vim/vim${_versiondir}/doc/uganda.txt \
+ "${pkgdir}"/usr/share/licenses/vim-runtime/license.txt
+}
+
+package_vim-cli-git() {
+ depends=("vim-cli-git-runtime" 'gpm' 'acl' 'glibc' 'libgcrypt' 'zlib')
+ optdepends=('python: Python language support'
+ 'lua: Lua language support'
+ 'perl: Perl language support'
+ 'cscope: cscope interface')
+ conflicts=('gvim' 'vim-minimal' 'vim')
+ provides=('vim' 'xxd' 'vim-minimal' 'vim-plugin-runtime')
+ replaces=('vim-minimal')
+
+ cd vim
+ make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+ # provided by (n)vi in core
+ rm "${pkgdir}"/usr/bin/{ex,view}
+
+ # delete some manpages
+ find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+ while read _mandir; do
+ cd "${_mandir}"
+ rm -f ex.1 view.1 # provided by (n)vi
+ rm -f evim.1 # this does not make sense if we have no GUI
+ done
+
+ # Runtime provided by runtime package
+ rm -r "${pkgdir}"/usr/share/vim
+
+ # remove gvim.desktop as not included
+ rm "${pkgdir}"/usr/share/applications/gvim.desktop
+
+ # license
+ install -Dm 644 runtime/doc/uganda.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+
+ # pacman hook for documentation helptags
+ install -Dm 644 "${srcdir}"/vimdoc.hook "${pkgdir}"/usr/share/libalpm/hooks/vimdoc.hook
+}
+
+# vim: ts=2 sw=2 et ft=sh:
diff --git a/archlinux.vim b/archlinux.vim
new file mode 100644
index 000000000000..2b71ccbe275d
--- /dev/null
+++ b/archlinux.vim
@@ -0,0 +1,46 @@
+" The Arch Linux global vimrc - setting only a few sane defaults
+"
+" DO NOT EDIT THIS FILE. IT'S OVERWRITTEN UPON UPGRADES.
+"
+" Use /etc/vimrc for system-wide and $HOME/.vimrc for personal configuration
+" (for details see ':help initialization').
+"
+" Use :help '<option>' to see the documentation for the given option.
+
+" Use Vim defaults instead of 100% vi compatibility
+" Avoid side-effects when nocompatible has already been set.
+if &compatible
+ set nocompatible
+endif
+
+set backspace=indent,eol,start
+set ruler
+set suffixes+=.aux,.bbl,.blg,.brf,.cb,.dvi,.idx,.ilg,.ind,.inx,.jpg,.log,.out,.png,.toc
+set suffixes-=.h
+set suffixes-=.obj
+
+" Move temporary files to a secure location to protect against CVE-2017-1000382
+if exists('$XDG_CACHE_HOME')
+ let &g:directory=$XDG_CACHE_HOME
+else
+ let &g:directory=$HOME . '/.cache'
+endif
+let &g:undodir=&g:directory . '/vim/undo//'
+let &g:backupdir=&g:directory . '/vim/backup//'
+let &g:directory.='/vim/swap//'
+" Create directories if they doesn't exist
+if ! isdirectory(expand(&g:directory))
+ silent! call mkdir(expand(&g:directory), 'p', 0700)
+endif
+if ! isdirectory(expand(&g:backupdir))
+ silent! call mkdir(expand(&g:backupdir), 'p', 0700)
+endif
+if ! isdirectory(expand(&g:undodir))
+ silent! call mkdir(expand(&g:undodir), 'p', 0700)
+endif
+
+" Make shift-insert work like in Xterm
+if has('gui_running')
+ map <S-Insert> <MiddleMouse>
+ map! <S-Insert> <MiddleMouse>
+endif
diff --git a/vimdoc.hook b/vimdoc.hook
new file mode 100644
index 000000000000..07af3cc50234
--- /dev/null
+++ b/vimdoc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/share/vim/vimfiles/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q"
+When = PostTransaction
diff --git a/vimrc b/vimrc
new file mode 100644
index 000000000000..ee36a5269244
--- /dev/null
+++ b/vimrc
@@ -0,0 +1,18 @@
+" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
+" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
+" you can find below. If you wish to change any of those settings, you should
+" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
+" everytime an upgrade of the vim packages is performed. It is recommended to
+" make changes after sourcing archlinux.vim since it alters the value of the
+" 'compatible' option.
+
+" This line should not be removed as it ensures that various options are
+" properly set to work with the Vim-related packages.
+runtime! archlinux.vim
+
+" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
+" Or better yet, read /usr/share/vim/vim80/vimrc_example.vim or the vim manual
+" and configure vim to your own liking!
+
+" do not load defaults if ~/.vimrc is missing
+"let skip_defaults_vim=1